summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTian Qiao2021-12-01 02:00:44 +0800
committerTian Qiao2021-12-01 02:00:44 +0800
commit85292bf6ca1397f4abfc0a744793bb1c12d9d34e (patch)
treeb8caa062e7da1e7b08d48031fb7e119ec85dbbd5 /PKGBUILD
downloadaur-85292bf6ca1397f4abfc0a744793bb1c12d9d34e.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c01986cf0300
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tian Qiao <abcnsxyz@gmail.com>
+
+pkgname=('pocsuite3')
+pkgver=1.8.6
+pkgrel=1
+pkgdesc='Open-sourced remote vulnerability testing framework'
+url='https://github.com/knownsec/pocsuite3'
+arch=('any')
+license=('GPL2')
+depends=('python-requests' 'python-pysocks' 'python-requests-toolbelt' 'python-urllib3'
+ 'python-chardet' 'python-termcolor' 'python-colorama' 'python-prettytable'
+ 'python-colorlog' 'python-scapy' 'python-faker')
+makedepends=('python-setuptools')
+optdepends=(
+ 'python-pyopenssl: self-signed certificate support'
+)
+source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('70ec8e1fdb68f349fb5c18a84396ebf331c4e2287e059183296a72a64876ac6f08b4205befa1e93893b9753d716505cfd92cfac1cac762440658f92d3d35a6c7')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ python setup.py install --skip-build -O1 --root="${pkgdir}"
+ install -Dm 644 *.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: