summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam2022-05-31 02:22:35 +0000
committerSam2022-05-31 02:22:35 +0000
commitabb4c3db9a64d7496fe771bb6e54a64e946555ee (patch)
tree184f0748a19cd72363d8cd5a52fb8019b230c4dd /PKGBUILD
parent34caeeb44282f0a22906582a02f4654a4f34a6de (diff)
downloadaur-abb4c3db9a64d7496fe771bb6e54a64e946555ee.tar.gz
updpkg: podman-git podman-docker-git 4.2.0_dev.r15273.ga550af260-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16d5766b0836..73ca702ba7a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,13 @@ pkgbase=podman-git
pkgname=(podman-git podman-docker-git)
_pkgname=podman
_pkgname_docker=podman-docker
-pkgver=4.0.0_dev.r13317.gabbd6c167
+pkgver=4.2.0_dev.r15273.ga550af260
pkgrel=1
pkgdesc="Tool and library for running OCI-based containers in pods (git)"
-arch=('any')
-depends=(cni-plugins conmon containers-common device-mapper iptables
- runc slirp4netns libsystemd fuse-overlayfs)
-makedepends=(go go-md2man git)
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+arch=(x86_64 aarch64)
+makedepends=(go go-md2man git gcc btrfs-progs catatonit libapparmor.so libdevmapper.so libgpgme.so libseccomp.so libsystemd)
+# https://github.com/containers/podman/issues/13297
+options=(!lto)
url="https://github.com/containers/$_pkgname.git"
license=(Apache)
source=("git+$url")
@@ -28,6 +26,9 @@ pkgver() {
}
build() {
+ # Fails if using clang
+ export CC=gcc
+ export CXX=g++
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -39,13 +40,17 @@ build() {
}
package_podman-git() {
- depends+=('libseccomp.so' 'libgpgme.so')
- optdepends+=('podman-docker: for Docker-compatible CLI'
+ depends+=(catatonit conmon containers-common crun iptables libdevmapper.so libgpgme.so libseccomp.so libsystemd slirp4netns netavark aardvark-dns)
+ optdepends+=(
'libapparmor.so: support for apparmor'
'libselinux: support for selinux'
'btrfs-progs: support btrfs backend devices'
- 'catatonit: --init flag support'
- 'crun: support for unified cgroupsv2')
+ 'cni-plugins: for the old cni networking implementation'
+ 'podman-compose: for docker-compose compatibility'
+ 'podman-docker: for Docker-compatible CLI'
+ )
+ provides=("$_pkgname" "$_pkgname-remote")
+ conflicts=("$_pkgname" "$_pkgname-remote")
cd $_pkgname || exit 1
make install install.completions DESTDIR="$pkgdir" PREFIX=/usr
@@ -56,13 +61,12 @@ package_podman-git() {
package_podman-docker-git() {
pkgdesc='Emulate Docker CLI using podman'
- depends=(podman)
+ depends=("$_pkgname")
conflicts=(docker)
provides=(docker)
cd $_pkgname || exit 1
make docker-docs EXTRA_LDFLAGS='-s -w -linkmode=external'
- make install.docker DESTDIR="$pkgdir" PREFIX=/usr
- make install.docker-docs DESTDIR="$pkgdir" PREFIX=/usr
+ make install.docker-full DESTDIR="$pkgdir" PREFIX=/usr
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname[1]}/LICENSE"
}