summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJianfeng Zhang2017-03-04 12:05:21 +0800
committerJianfeng Zhang2017-03-04 12:05:21 +0800
commitb9599458f2b62a561fffcacc0bc9a01a5a861e5d (patch)
tree84de3123a30bcf428a437aae1b705c838d3cb261 /PKGBUILD
parentb3b49651020ff0536b71c179caa6299b57876c63 (diff)
downloadaur-b9599458f2b62a561fffcacc0bc9a01a5a861e5d.tar.gz
auto check latest tag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 923640b25509..e2ed7fc77c89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,6 @@
pkgname=poi
_pkgname=poi
pkgver=7.4.1.0.gf6a1fc73
-_pkgver=7.4.1
pkgrel=1
pkgdesc="Scalable KanColle browser and tool"
arch=('any')
@@ -13,13 +12,18 @@ depends=('electron' 'sh')
makedepends=('git' 'npm' 'coreutils' 'findutils' 'sed' 'imagemagick' 'tar' 'zlib' 'unzip' 'gulp')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("git+https://github.com/poooi/poi.git#tag=v${_pkgver}"
+source=("git+https://github.com/poooi/poi.git"
"${_pkgname}.desktop"
"${_pkgname}.sh")
sha1sums=('SKIP'
'0578634a64fbb2de2fd35555471a761231a3dc94'
'321cecdb8f68fb087dfcaa1233ae5ce784095029')
+prepare() {
+ cd ${srcdir}/${pkgname}
+ git checkout -f $(git describe --tags $(git rev-list --tags --max-count=1))
+}
+
pkgver() {
cd "${srcdir}/${_pkgname}"
git describe --tags --long | sed 's/^v//;s/-/./g'