aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgeorgew2018-04-29 01:53:01 -0500
committergeorgew2018-04-29 01:53:01 -0500
commit84fc93a0911debb9b3a1445455ea4ddd07537e92 (patch)
tree3954c223721e9c55e5af3611a29c3fdd2075a379 /PKGBUILD
parentd893acaf65c9687e39a720ef639b577fef0325df (diff)
downloadaur-84fc93a0911debb9b3a1445455ea4ddd07537e92.tar.gz
Update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c66cad7abfe6..2eb5dc48cc6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
# Contributer: WyRe
pkgname="pokemmo"
-pkgver=1.2.1
+pkgver=1.3
pkgrel=1
pkgdesc="MMO based on the Pokémon Universe"
-arch=('any')
-url="http://pokemmo.eu"
+arch=('x86_64' 'i686')
+url="https://pokemmo.eu"
license=('custom')
-depends=('java-runtime')
+depends=('java-runtime' 'wget' 'openssl')
+optdepends=('zenity: Information/Error message UI')
install="${pkgname}.install"
-source=("https://pokemmo.eu/download_file/?id=5/${pkgname}_${pkgver}.rpm")
-sha256sums=('dc37446213a95bd6c8b8192514c68bd8ad69b53ccc6ffc18512fb5c59cd4dc07')
+source=('pokemmo-launcher' 'pokemmo.desktop' 'pokemmo-launcher.png')
+sha256sums=('c3db3b0d03db8bde29591947302ea773135c82096f6e0c15abc367c636bdde66'
+'5be349827e2798bce275c16a554ab32f5aa3cf62859200effa5328c26d1233dc'
+'50d0c73eb7e23dcec4c36304cb9008a448e8127628eadb1166c3343f6fdd5ee3')
package(){
- install -Dm755 "${srcdir}/usr/bin/pokemmo-launcher" "${pkgdir}/usr/bin/pokemmo-launcher"
- cp -r "${srcdir}/usr/share" "${pkgdir}/usr/share"
+ install -Dm755 "pokemmo-launcher" "${pkgdir}/usr/bin/pokemmo-launcher"
+ install -Dm644 "pokemmo.desktop" "${pkgdir}/usr/share/applications/pokemmo.desktop"
+ install -Dm644 "pokemmo-launcher.png" "${pkgdir}/usr/share/pixmaps/pokemmo-launcher.png"
}