summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Bornschein2020-09-16 22:55:44 +0200
committerFabian Bornschein2020-09-16 22:55:44 +0200
commit5ff1e4f29a30e10f036abec9d5bb481d12599718 (patch)
tree2623f27d6de2c7b7bc7ab30ab059a46b58c749a7 /PKGBUILD
parentedf961f6438e7eb5af8154f8455c6b231cb83848 (diff)
downloadaur-5ff1e4f29a30e10f036abec9d5bb481d12599718.tar.gz
new upstream release, name changing, versionstring changing to rel-date+asset-version+maybeclientversion because PRO does not provide a real version string anymore.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cfb172e17b89..12c797c96361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Fabian <plusfabi[AT+thegoogleadress]>
pkgname=pokemon-revolution-online-bin
-__DATA_VER=0.3.1
-pkgver=0.98.5.20200913_${__DATA_VER}.megav2
+__LIN_DESKTOP_ASSET_VER=0.3.2
+__PROCLIENT_VER=0.98.5
+pkgver=20200821+${__LIN_DESKTOP_ASSET_VER}+${__PROCLIENT_VER}
pkgrel=1
pkgdesc="A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games."
arch=('x86_64')
-url="https://pokemon-revolution-online.net"
+url="https://pokemonrevolution.net"
license=('custom')
-depends=('desktop-file-utils')
-makedepends=('xdg-utils')
+depends=('vulkan-driver' 'opengl-driver')
optdepends=('gtk2: required for the Unity ScreenSelector plugin')
conflicts=('pokemon-revolution-online')
-install=$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install
-source=("https://gitlab.com/fabis_cafe/pokemon-revolution-online-data/-/archive/${__DATA_VER}/pokemon-revolution-online-data-${__DATA_VER}.zip"
+install="$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install"
+source=("git+https://gitlab.com/fabis_cafe/pro_assets_lin_desktop.git#tag=${__LIN_DESKTOP_ASSET_VER}"
"PROClient_linux.7z::https://ddl.pokemonrevolution.net/PROClient_linux.7z"
)
-sha256sums=('ab38844feddb7b3df18ad7149272b908c63ecc5c654005188cfaf9db5b05b3c4'
+sha256sums=('SKIP'
'9b127ad358bf3f0fbe72271cb31b465a01d422a09f5715adaa7755e2adfd85a3')
package() {
@@ -49,18 +49,18 @@ package() {
#MOVE ICON
## The original icon is proprietary with a license that don't allows changes to the overall content.
## Don't use the original icon for the '.desktop entry because of this.
- /usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/net.pokemonrevolution.svg" \
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/net.pokemonrevolution.svg" \
"${pkgdir}/usr/share/pixmaps/net.pokemonrevolution.svg"
# DESKTOP FILE
- /usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/net.pokemonrevolution.desktop" \
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/net.pokemonrevolution.desktop" \
"${pkgdir}/usr/share/applications/net.pokemonrevolution.desktop"
# START SCRIPT
- /usr/bin/install -D -m755 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/PROClient" \
+ /usr/bin/install -D -m755 "${srcdir}/pro_assets_lin_desktop/PROClient" \
"${pkgdir}/usr/bin/PROClient"
# COPYRIGHT FILE
- /usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/pkg_copyright" \
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/pkg_copyright" \
"${pkgdir}/usr/share/licenses/pokemon-revolution-online-bin/copyright"
}