summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Bornschein2021-03-09 16:19:32 +0100
committerFabian Bornschein2021-03-09 16:19:32 +0100
commit7fef1784c48d2cb736bfe48036cc8021301565a2 (patch)
treeab40754e83e5b869c6322ad1fce0c0a82e570870 /PKGBUILD
parentbd8e0a03aef4bd92254b1fdce3ad64fa55550d15 (diff)
downloadaur-7fef1784c48d2cb736bfe48036cc8021301565a2.tar.gz
asset update, new mail, PKGBUILD update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD86
1 files changed, 43 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9632b85255a..d6868f892bcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Fabian Bornschein <plusfabi-cat-gmail-dog-com>
+# Maintainer: Fabian Bornschein <fabiscafe@mailbox.org>
pkgname=pokemon-revolution-online-bin
-__LIN_DESKTOP_ASSET_VER=0.3.2
+__LIN_DESKTOP_ASSET_VER=0.4
__PROCLIENT_VER=20210215
pkgver=${__PROCLIENT_VER}+${__LIN_DESKTOP_ASSET_VER}
-pkgrel=2
+pkgrel=1
pkgdesc="A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games."
arch=('x86_64')
url="https://pokemonrevolution.net"
@@ -15,53 +15,53 @@ optdepends=('gtk2: required for the Unity ScreenSelector plugin')
conflicts=('pokemon-revolution-online')
install="archlinux.install"
source=("git+https://gitlab.com/fabis_cafe/pro_assets_lin_desktop.git#tag=${__LIN_DESKTOP_ASSET_VER}"
- "PROClient_linux-${__PROCLIENT_VER}.zip::https://ddl.pokemonrevolution.net/PROClient_linux.zip"
+ "PROClient_linux-${__PROCLIENT_VER}.zip::https://ddl.pokemonrevolution.net/PROClient_linux.zip"
)
sha256sums=('SKIP'
'eb68484c94b929beb438ea78feee83566d7c8c204d83eec83facef4a75cf66b5')
package() {
- #PROCLIENT PART
- ###############
-
- # CREATE: directory structure
- /usr/bin/install -dm755 "${pkgdir}/opt/PROClient"
-
- ## This uses "." as current dir, in order to not have the whole build path (for many /home/user/blabla)
- ## in the install path. srcdir needs to be the starting point.
- cd "${srcdir}/PROClient"
- /usr/bin/find . \
- -type d \
- -exec \
- /usr/bin/install -dm755 "${pkgdir}/opt/PROClient/{}" \;
-
- # INSTALL:
- /usr/bin/find . \
- -type f \
- ! -name "PROClient.x86_64" \
- -exec \
- /usr/bin/install -m644 "{}" "${pkgdir}/opt/PROClient/{}" \;
+ #PROCLIENT PART
+ ###############
- /usr/bin/install -m755 "${srcdir}/PROClient/PROClient.x86_64" "${pkgdir}/opt/PROClient/PROClient.x86_64"
+ # CREATE: directory structure
+ /usr/bin/install -dm755 "${pkgdir}/opt/PROClient"
- #_DATA PART
- ###########
-
- #MOVE ICON
- ## The original icon is proprietary with a license that don't allows changes to the overall content.
- ## Don't use the original icon for the '.desktop entry because of this.
- /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/net.pokemonrevolution.svg" \
- "${pkgdir}/usr/share/pixmaps/net.pokemonrevolution.svg"
-
- # DESKTOP FILE
- /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/net.pokemonrevolution.desktop" \
- "${pkgdir}/usr/share/applications/net.pokemonrevolution.desktop"
+ ## This uses "." as current dir, in order to not have the whole build path (for many /home/user/blabla)
+ ## in the install path. srcdir needs to be the starting point.
+ cd "${srcdir}/PROClient"
+ /usr/bin/find . \
+ -type d \
+ -exec \
+ /usr/bin/install -dm755 "${pkgdir}/opt/PROClient/{}" \;
+
+ # INSTALL
+ /usr/bin/find . \
+ -type f \
+ ! -name "PROClient.x86_64" \
+ -exec \
+ /usr/bin/install -m644 "{}" "${pkgdir}/opt/PROClient/{}" \;
- # START SCRIPT
- /usr/bin/install -D -m755 "${srcdir}/pro_assets_lin_desktop/PROClient" \
- "${pkgdir}/usr/bin/PROClient"
+ /usr/bin/install -m755 "${srcdir}/PROClient/PROClient.x86_64" "${pkgdir}/opt/PROClient/PROClient.x86_64"
- # COPYRIGHT FILE
- /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/pkg_copyright" \
- "${pkgdir}/usr/share/licenses/pokemon-revolution-online-bin/copyright"
+ #_DATA PART
+ ###########
+
+ #MOVE ICON
+ ## The original icon is proprietary with a license that don't allows changes to the overall content.
+ ## Don't use the original icon for the '.desktop entry because of this.
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/net.pokemonrevolution.svg" \
+ "${pkgdir}/usr/share/pixmaps/net.pokemonrevolution.svg"
+
+ # DESKTOP FILE
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/net.pokemonrevolution.desktop" \
+ "${pkgdir}/usr/share/applications/net.pokemonrevolution.desktop"
+
+ # START SCRIPT
+ /usr/bin/install -D -m755 "${srcdir}/pro_assets_lin_desktop/PROClient" \
+ "${pkgdir}/usr/bin/PROClient"
+
+ # COPYRIGHT FILE
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/pkg_copyright" \
+ "${pkgdir}/usr/share/licenses/pokemon-revolution-online-bin/copyright"
}