summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabian Bornschein2020-09-12 16:28:33 +0200
committerFabian Bornschein2020-09-12 16:28:33 +0200
commitb8f5d4824e5ff3119c31dd1b83c653564121b216 (patch)
tree081f3a0852e6df1a4281591b94bc47d5f34bfbfa /PKGBUILD
parent68b17cafe7d168f3c3a80d12843cc09b366e7802 (diff)
downloadaur-b8f5d4824e5ff3119c31dd1b83c653564121b216.tar.gz
New upstream release, pkgbuild re-do, _DATA changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD118
1 files changed, 42 insertions, 76 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad04c0cb9394..ee2f13c0ede5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fabian <plusfabi[AT+thegoogleadress]>
pkgname=pokemon-revolution-online-bin
-pkgver=0.98.4.2.rootsedition
-pkgrel=2
+pkgver=0.98.5.20200912.megav2
+pkgrel=1
pkgdesc="A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games."
arch=('x86_64')
url="https://pokemon-revolution-online.net"
@@ -11,91 +11,57 @@ depends=('gcc-libs' 'desktop-file-utils')
makedepends=('unzip' 'xdg-utils')
optdepends=('gtk2: required for the Unity ScreenSelector plugin')
conflicts=('pokemon-revolution-online')
-install="INSTALL"
-__DATA_VER=0.1.1
-source=("https://gitlab.com/Fabish/pokemon-revolution-online-data/-/archive/${__DATA_VER}/pokemon-revolution-online-data-${__DATA_VER}.zip")
-sha256sums=('533d250127b85054f4aa087857b130e7a21525ce6382aefd63adb564f4125212')
+install=$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install
+__DATA_VER=0.2
+source=("https://gitlab.com/fabis_cafe/pokemon-revolution-online-data/-/archive/${__DATA_VER}/pokemon-revolution-online-data-${__DATA_VER}.zip"
+ "PROClient_linux.7z::https://ddl.pokemonrevolution.net/PROClient_linux.7z"
+)
+sha256sums=('1bf2b078c4f226bd8716e1b6c680e9545dc6491e0de067ecf5105553aa90ba46'
+ '9b127ad358bf3f0fbe72271cb31b465a01d422a09f5715adaa7755e2adfd85a3')
package() {
- cd "${srcdir}"
-
- # Variables
- ## directory files naming is usually VNAMING_Data, binary VNAMING.x86_64
- __VNAMING="PRO" ##like PROLinux95_45_data, PROLinux95_45.x86_64
-
- __DLDIR=$(xdg-user-dir DOWNLOAD) ##download directory
- __DDLA="https://tiny.cc/PROLinux" ##download link
- __DDLFN="PROLINUX.zip" ##filename
- __DDLFSHA256="2e506cfb5bbe70695eeac4ca52b57b6668cc8ac0a502de08fac976780be4b038" #sha256sum
-
- ## Check for the download file
- if [ ! -f ${__DLDIR}/${__DDLFN} ]; then
- {
- printf "${__DLDIR}/${__DDLFN} not found, please download it\n"
- printf "Download: ${__DDLA}\n"
- exit 1
- }
- fi
- ## sha256sum check
- if [ "$(sha256sum ${__DLDIR}/${__DDLFN} | awk '{printf $1}')" != "${__DDLFSHA256}" ]; then
- {
- printf "${__DLDIR}/${__DDLFN} SHA256 MISMATCH, please remove the old file before downloading\n"
- printf "rm \"${__DLDIR}/${__DDLFN}\"\n"
- printf "Download: ${__DDLA}\n\n"
- printf "maybe this pkgbuild is out-of-date. please report this:\n"
- printf "https://aur.archlinux.org/packages/pokemon-revolution-online-bin/\n"
- exit 1
- }
- fi
-
- #bsdtar -x -p -f "${__DLDIR}/${__DDLFN}"
- ## we're using unzip for now, since bsdtar cant handle the zip file
- ## bsdtar: Invalid central directory signature
- ## bsdtar: Error exit delayed from previous errors.
- /usr/bin/unzip "${__DLDIR}/${__DDLFN}"
-
- # CREATE FOLDERS
- ## copy the folderstructure of the original without content.
- /usr/bin/find "." -type d -exec \
- /usr/bin/install -d -m755 "${pkgdir}/opt/Pokemon Revolution/{}" \;
-
- # MOVE CONTENT
- ## minimize memory usage by using mv instead of install
- ## this also fits more in our "permissions" to use it hashtag copyright, hashtag do NOT modify anything
- /usr/bin/find "./${__VNAMING}_Data" \
+ #PROCLIENT PART
+ ###############
+
+ # CREATE: directory structure
+ /usr/bin/install -dm755 "${pkgdir}/opt/PROClient"
+
+ ## This uses "." as current dir, in order to not have the whole build path (for many /home/user/blabla)
+ ## in the install path. srcdir needs to be the starting point.
+ cd "${srcdir}/PROClient"
+ /usr/bin/find . \
+ -type d \
+ -exec \
+ /usr/bin/install -dm755 "${pkgdir}/opt/PROClient/{}" \;
+
+ # INSTALL:
+ /usr/bin/find . \
-type f \
- -exec /usr/bin/mv "{}" "${pkgdir}/opt/Pokemon Revolution/{}" \; \
- -exec /usr/bin/chmod 644 "${pkgdir}/opt/Pokemon Revolution/{}" \;
- ## move to new position
- /usr/bin/mv "${srcdir}/${__VNAMING}.x86_64" "${pkgdir}/opt/Pokemon Revolution/${__VNAMING}.x86_64"
- ## set permission
- /usr/bin/chmod 755 "${pkgdir}/opt/Pokemon Revolution/${__VNAMING}.x86_64"
+ ! -name "PROClient.x86_64" \
+ -exec \
+ /usr/bin/install -m644 "{}" "${pkgdir}/opt/PROClient/{}" \;
- #MOVE ICON
- ## cause we can not use the iroginal icon, we use a *.svg version.
- /usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/pokemonrevolution.svg" \
- "${pkgdir}/usr/share/pixmaps/pokemonrevolution.svg"
+ /usr/bin/install -m755 "${srcdir}/PROClient/PROClient.x86_64" "${pkgdir}/opt/PROClient/PROClient.x86_64"
+ #_DATA PART
+ ###########
+
+ #MOVE ICON
+ ## The original icon is proprietary with a license that don't allows changes to the overall content.
+ ## Don't use the original icon for the '.desktop entry because of this.
+ /usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/proclient.svg" \
+ "${pkgdir}/usr/share/pixmaps/proclient.svg"
+
# DESKTOP FILE
- ## Set the path to our pokemon scriptfile
- /usr/bin/sed -i "s/GAMEEXECPATHSETBYPKGBUILD/\/usr\/bin\/pokemonrevolution/" "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/net.pokemon-revolution-online.desktop"
- ## let's Install the *.desktop file
/usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/net.pokemon-revolution-online.desktop" \
- "${pkgdir}/usr/share/applications/net.pokemon-revolution-online.desktop"
+ "${pkgdir}/usr/share/applications/net.pokemon-revolution-online.desktop"
# START SCRIPT
- ## set the correct directory
- /usr/bin/sed -i "s/GAMEDIRNAMESETBYPKGBUILD/\/opt\/Pokemon\ Revolution/" "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/pokemonrevolution"
- ## set the correct filename
- /usr/bin/sed -i "s/GAMEBINARYNAMESETBYPKGBUILD/${__VNAMING}.x86_64/" "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/pokemonrevolution"
-
- ## move it!
- /usr/bin/install -D -m755 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/pokemonrevolution" \
- "${pkgdir}/usr/bin/pokemonrevolution"
+ /usr/bin/install -D -m755 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/PROClient" \
+ "${pkgdir}/usr/bin/PROClient"
# COPYRIGHT FILE
- ## move the copyright text
/usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/pkg_copyright" \
- "${pkgdir}/usr/share/licenses/pokemon-revolution-online-bin/copyright"
+ "${pkgdir}/usr/share/licenses/pokemon-revolution-online-bin/copyright"
}