summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHelton Reis2021-05-24 19:34:38 -0300
committerHelton Reis2021-05-24 19:34:38 -0300
commitdcda47c7634dd667ac2a37cfa8ccb10af0107ecb (patch)
tree9c193e2e9ac2565379922f6679cf7b30af6cd2de /PKGBUILD
downloadaur-dcda47c7634dd667ac2a37cfa8ccb10af0107ecb.tar.gz
[misc] Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40687f52286c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: HRKings <hrkings@***.com>
+pkgname=pokemonsay-newgenerations-git
+_pkgname=pokemonsay-newgenerations
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Brings pokemon to the terminal using the power of cowsay."
+arch=(any)
+url="https://github.com/HRKings/pokemonsay-newgenerations.git"
+license=('unknown')
+depends=(cowsay)
+provides=(pokemonsay)
+source=("git+${url}")
+md5sums=('SKIP')
+
+package() {
+ cd ${_pkgname}
+ # Copy pokemon cowfiles
+ rm -rf "${pkgdir}/opt/${_pkgname}/pokemons"
+ mkdir -p "${pkgdir}/opt/${_pkgname}/pokemons"
+ cp ./pokemons/* "${pkgdir}/opt/${_pkgname}/pokemons/"
+
+ # Install the README
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+
+ # Put the installation path on the script
+ sed -r "31s;.*;INSTALL_PATH=${pkgdir}/opt/${_pkgname}/;" -i pokemonsay.sh
+
+ # Install the scripts
+ install -Dm755 pokemonsay.sh "${pkgdir}"/usr/bin/pokemonsay
+ install -Dm755 pokemonthink.sh "${pkgdir}"/usr/bin/pokemonthink
+} \ No newline at end of file