summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortinywrkb2021-10-16 01:16:30 +0300
committertinywrkb2021-10-16 01:16:30 +0300
commit0913dc112d1707d555ae38ffc4ba8cf2e1cd971f (patch)
treef3598f3bc42b73c7ac87c2c4f9d9aea906f5e6c9 /PKGBUILD
parent2d22260e2f0c657f23adb7b128c8f798266bf35c (diff)
downloadaur-0913dc112d1707d555ae38ffc4ba8cf2e1cd971f.tar.gz
bump to 0.120-2: use resurrected MR, switch to meson
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 21 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8395bd07781..ccf386fbb481 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,23 @@
_pkgname=polkit
pkgname=${_pkgname}-duktape
-pkgver=0.119
-pkgrel=1
+pkgver=0.120
+pkgrel=2
pkgdesc="polkit with duktape as the javascript engine"
arch=(x86_64)
license=(LGPL)
url="https://www.freedesktop.org/wiki/Software/polkit/"
depends=(glib2 pam expat systemd duktape)
-makedepends=(intltool gtk-doc gobject-introspection git autoconf-archive)
+makedepends=(meson gtk-doc gobject-introspection git)
+checkdepends=(python-dbusmock)
conflicts=(polkit)
provides=(polkit)
backup=(etc/pam.d/polkit-1)
-_commit=2e5348bf4eb0ef984db32f7f96ec6722d441c6ca # tags/0.119
+_commit=92b910ce2273daf6a76038f6bd764fa6958d4e8e # tags/0.120
source=("git+https://gitlab.freedesktop.org/polkit/polkit.git#commit=$_commit"
"0001-Add-duktape-as-javascript-engine.patch")
sha256sums=('SKIP'
- 'b7ffa913e2c6f9ba0ab70e09b2b9d735af909acd128f9b94f4b812914d96eefb')
+ 'a7f8925d074c3bc42b1e3bc09305d047014fc209724e4e9609a1275bf1f3c3a8')
pkgver() {
cd $_pkgname
@@ -28,34 +29,32 @@ pkgver() {
prepare() {
cd $_pkgname
patch -p1 -i ../0001-Add-duktape-as-javascript-engine.patch
- NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd $_pkgname
-
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib \
- --enable-libsystemd-login=yes --disable-static \
- --enable-gtk-doc --with-os-type=redhat --with-duktape
-
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ local meson_options=(
+ --prefix=/usr
+ -D session_tracking=libsystemd-login
+ -D os_type=redhat
+ -D examples=true
+ -D tests=true
+ -D gtk_doc=true
+ -D man=true
+ -D js_engine=duktape
+ )
+ arch-meson polkit build "${meson_options[@]}"
+ meson compile -C build
}
check() {
- cd $_pkgname
- make -k check || :
+ meson test -C build --print-errorlogs
}
package() {
- cd $_pkgname
- make DESTDIR="$pkgdir" install \
- dbusconfdir=/usr/share/dbus-1/system.d \
- rulesdir=/usr/share/polkit-1/rules.d
+ meson install -C build --destdir "$pkgdir"
install -d -o root -g 102 -m 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
+ mv "$pkgdir"/{etc,usr/share}/polkit-1/rules.d/50-default.rules
install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf" <<END
u polkitd 102 "PolicyKit daemon"