summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLightDot2018-02-22 21:45:00 +0100
committerLightDot2018-02-22 21:45:00 +0100
commit5eed1461e557bf937f331f69e0a97231094e9cb4 (patch)
treefed8d7837916c5acf8a34c4f42751dd24e5ded72 /PKGBUILD
parenta5ec6c41de5245281ef3c48162b47da835db2a1f (diff)
downloadaur-5eed1461e557bf937f331f69e0a97231094e9cb4.tar.gz
PKGBUILD cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f6970f2b38f..001458bcf2a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-
# Maintainer: LightDot <lightdot a-t- g m a i l>
+
_pkgname=polkit-efl
pkgname=$_pkgname-git
pkgver=0.1.0.r8.g6417565
pkgrel=1
-pkgdesc="Polkit Authentication Agent using EFL - Development version"
+pkgdesc="Enlightenment polkit authentication agent using EFL - development version."
arch=('any')
url="http://www.enlightenment.org"
-license=('GPL3' 'LGPL: Icons')
+license=('GPL3' 'LGPL') # LGPL for icons
depends=('python-efl' 'polkit')
makedepends=('git' 'mesa')
optdepends=('python-psutil: For process details')
@@ -16,19 +16,16 @@ conflicts=("$_pkgname")
source=("git+https://git.enlightenment.org/misc/$_pkgname.git")
sha256sums=('SKIP')
-
pkgver() {
cd "$srcdir/$_pkgname"
git describe --tags --long | sed 's/^v//;s/-/.r/;s/-/./g'
}
-
build() {
cd "$srcdir/$_pkgname"
python setup.py build
}
-
package() {
cd "$srcdir/$_pkgname"
python setup.py install --root="${pkgdir}"