summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2020-08-19 19:04:45 +0200
committerFabioLolix2020-08-19 19:04:45 +0200
commitd744732b17bb4fa417ae5a1bee953e505db53b92 (patch)
tree6b56d5bd433be000766c081be47ac23bade417a1 /PKGBUILD
parent82cb174564995b65f9fdf0a7e0a8b0957dd13866 (diff)
downloadaur-polo.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8026b9d3ed09..f22d0fe3a29d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=polo
-pkgrel=1
pkgver=18.8.3
+pkgrel=2
pkgdesc="A modern, light-weight GTK file manager for Linux, currently in beta"
arch=(686 x86_64)
url="https://teejee2008.github.io/polo/"
@@ -20,13 +20,16 @@ optdepends=('mediainfo: read media properties from audio and video files'
'polo-donation-plugins')
_commit=538be6950d9394c90aa90be3973a3c8d9a27b999
source=("${pkgname}-${pkgver}-${_commit}.tar.gz::https://github.com/teejee2008/polo/archive/${_commit}.tar.gz"
- '0001-Re-add-support-for-vte291-0.52.patch')
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/polo-Re-add-support-for-vte291-0.52.patch"
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/polo-fix-build.patch")
sha256sums=('ac96ad931024d7b96d5458f963753bf2bc92dc697dbfe5bb8bbc90aa98824443'
- '4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f')
+ '4ae33547220a7bfb7cd9806bd121acbc54c35a06958d40aa3cb1621688b5f69f'
+ '895c7f21844fead0df7b044396ee972f55cd03e4cb5a218adc30e1605e274f45')
prepare() {
cd "${pkgname}-${_commit}"
- patch -Np1 -i ../0001-Re-add-support-for-vte291-0.52.patch
+ patch -Np1 -i ../polo-Re-add-support-for-vte291-0.52.patch
+ patch -Np1 -i ../polo-fix-build.patch
}
build() {