summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Carlberg2016-11-19 06:09:15 +0100
committerMichael Carlberg2016-11-19 06:09:17 +0100
commit3fdbbadf6b2b5d80cf80521fd8c8068ada1031dd (patch)
tree432520c6b905ce7a222573240c87625267a1f801 /PKGBUILD
downloadaur-3fdbbadf6b2b5d80cf80521fd8c8068ada1031dd.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56ab6af91621
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Michael Carlberg <c@rlberg.se>
+# Contributor: Michael Carlberg <c@rlberg.se>
+pkgname=polybar
+pkgver=2.2.8
+pkgrel=1
+pkgdesc="A fast and easy-to-use status bar"
+arch=("i686" "x86_64")
+url="https://github.com/jaagr/polybar"
+license=("MIT")
+depends=("libxft" "xcb-util-wm" "xcb-util-image")
+optdepends=("alsa-lib: volume module support"
+ "libmpdclient: mpd module support"
+ "wireless_tools: network module support"
+ "jsoncpp: i3 module support"
+ "i3ipc-glib-git: i3 module support")
+makedepends=("cmake" "python2" "pkg-config" "boost")
+conflicts=("polybar-git" "lemonbuddy-git" "lemonbuddy")
+source=("${pkgname}::git+${url}.git#tag=${pkgver}")
+md5sums=("SKIP")
+
+prepare() {
+ cd "$pkgname" || exit
+ git submodule update --init --recursive
+ mkdir build
+}
+
+build() {
+ cd "${pkgname}/build" || exit
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "${pkgname}/build" || exit
+ make DESTDIR="${pkgdir}/" install
+ cd .. || exit
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}