summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpatrick962017-12-03 18:10:43 +0100
committerpatrick962017-12-03 18:10:43 +0100
commitb4c7530c63e487a89c393060fe072c05e861094d (patch)
tree9eb1f2de12e8259e8fe83be827f9b2eca15a2af8 /PKGBUILD
parent07f332ffa3d52244350930e5144c018c4c29be75 (diff)
downloadaur-b4c7530c63e487a89c393060fe072c05e861094d.tar.gz
Version 3.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 548c7b1840cb..56c41d4786f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Michael Carlberg <c@rlberg.se>
# Contributor: Michael Carlberg <c@rlberg.se>
pkgname=polybar
-pkgver=3.0.5
-pkgrel=4
+pkgver=3.1.0
+pkgrel=1
pkgdesc="A fast and easy-to-use status bar"
arch=("i686" "x86_64")
url="https://github.com/jaagr/polybar"
@@ -16,7 +16,7 @@ optdepends=("alsa-lib: volume module support"
"ttf-unifont: Font used in example config"
"siji-git: Font used in example config"
"curl: github module support")
-makedepends=("clang" "cmake" "git" "python" "python2" "pkg-config")
+makedepends=("cmake" "git" "python" "python2" "pkg-config")
conflicts=("polybar-git")
install="${pkgname}.install"
source=("${pkgname}::git+${url}.git#tag=${pkgver}")
@@ -24,13 +24,12 @@ md5sums=("SKIP")
prepare() {
git -C "${pkgname}" submodule update --init --recursive
- git -C "${pkgname}" cherry-pick -n d35abc7620c8f06618b4708d9a969dfa2f309e96
mkdir -p "${pkgname}/build"
}
build() {
cd "${pkgname}/build" || exit 1
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_COMPILER="clang" -DCMAKE_CXX_COMPILER="clang++" ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
cmake --build .
}