summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpatrick962020-12-02 18:32:40 +0100
committerpatrick962020-12-02 18:32:40 +0100
commitcb488ee11fa0b7ba130a11e3da04e239c93079b7 (patch)
treead42a26c923fc3eb74e63ed07aa93f0cdc10a529 /PKGBUILD
parent6d5fd9c0ee313f4695928f1091d25785e89282fe (diff)
downloadaur-cb488ee11fa0b7ba130a11e3da04e239c93079b7.tar.gz
Release 3.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f347d6ff7de8..fa68c05fe24d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Patrick Ziegler <p.ziegler96@gmail.com>
pkgname=polybar
-pkgver=3.4.3
-pkgrel=2
+pkgver=3.5.0
+pkgrel=1
pkgdesc="A fast and easy-to-use status bar"
arch=("i686" "x86_64")
url="https://github.com/polybar/polybar"
@@ -16,7 +16,7 @@ makedepends=("cmake" "git" "python" "pkg-config" "python-sphinx" "i3-wm")
conflicts=("polybar-git")
install="${pkgname}.install"
source=(${url}/releases/download/${pkgver}/polybar-${pkgver}.tar)
-sha256sums=('d4ed121c1d3960493f8268f966d65a94d94c4646a4abb131687e37b63616822f')
+sha256sums=('e8c1798c195854852fc7c99703287294123381101b371f171d4aa540aeb17afd')
prepare() {
mkdir -p "${pkgname}/build"
@@ -24,7 +24,8 @@ prepare() {
build() {
cd "${pkgname}/build" || exit 1
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ # Force cmake to use system python (to detect xcbgen)
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DPYTHON_EXECUTABLE=/usr/bin/python3 ..
cmake --build .
}