summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2015-08-19 07:43:48 +0200
committerJ5lx2015-08-19 07:43:48 +0200
commit8bb0417c0a4b286be8cc64523f793fac0e485ec3 (patch)
tree2bb4209707bbc59c2c663a4e6637e58b7f37a55a /PKGBUILD
downloadaur-8bb0417c0a4b286be8cc64523f793fac0e485ec3.tar.gz
1ed8a49-1: Initial package release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21dad5eab974
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=polyglot-winboard-git
+pkgver=1ed8a49
+pkgrel=1
+pkgdesc="UCI to XBoard adapter (WinBoard fork)"
+arch=('i686' 'x86_64')
+url="http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=summary"
+license=('GPL2')
+depends=('glibc')
+# If anyone knows the URL of the actual repository, please tell me!
+source=("polyglot.tar.gz::http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=snapshot;h=refs/heads/learn;sf=tgz")
+md5sums=('SKIP')
+
+_enter_polyglot_directory() {
+ cd $(ls -lt --color=never $srcdir | grep '^d' | grep -Eo 'polyglot-learn-[a-f0-9]+$' | head -n1)
+}
+
+pkgver() {
+ _enter_polyglot_directory
+
+ pwd | grep -Po '[a-f0-9]+$'
+}
+
+build() {
+ _enter_polyglot_directory
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ _enter_polyglot_directory
+
+ make DESTDIR="${pkgdir}" install
+}