summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLenny McLennington2022-02-27 13:37:20 +0000
committerLenny McLennington2022-02-27 13:37:20 +0000
commita10b3ca1655b7fa1ca1f4b9ebd6a90ac68cffbda (patch)
treed6fe2365579a2220f5f4a10e80a87a9a9a4e78d8 /PKGBUILD
parentee4858279462be5b1ec454ce5903ccb91f34bb9c (diff)
downloadaur-a10b3ca1655b7fa1ca1f4b9ebd6a90ac68cffbda.tar.gz
Make builds systems other than Make work
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f67371b9b968..9b50b43fc20b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,16 +52,16 @@ build() {
-DLauncher_APP_BINARY_NAME="${_pkgname}" \
-DLauncher_SHARE_DEST_DIR="share/${_pkgname}" \
..
- make
+ cmake --build .
}
check() {
cd "${srcdir}/PolyMC/build"
- make test
+ ctest .
}
package() {
cd "${srcdir}/PolyMC/build"
- make install DESTDIR="${pkgdir}"
+ cmake --install . --prefix "${pkgdir}"
}