summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-07-11 10:12:49 +0200
committerSefa Eyeoglu2022-07-11 10:12:49 +0200
commit793bb0289ea58da708a8a886ed4594de2b7b0b49 (patch)
treedc32ece660108f5f9080f6296e24908aa4d7c421 /PKGBUILD
parentf2628650bc9a7e2c7c5fcfdf8b5b3104bca694f0 (diff)
downloadaur-793bb0289ea58da708a8a886ed4594de2b7b0b49.tar.gz
upgpkg: polymc-qt5-git 1.3.1.r295.gac8ee9f9-2
minor refactor
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73fd1f32b28b..b9479c852ac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=polymc
pkgname=${_pkgname}-qt5-git
pkgver=1.3.1.r295.gac8ee9f9
-pkgrel=1
+pkgrel=2
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64')
url="https://github.com/PolyMC/PolyMC"
@@ -30,12 +30,12 @@ sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd PolyMC
+ cd "PolyMC"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/PolyMC"
+ cd "PolyMC"
git submodule init
git config submodule.libnbtplusplus.url "${srcdir}/libnbtplusplus"
git config submodule.quazip.url "${srcdir}/quazip"
@@ -43,24 +43,22 @@ prepare() {
}
build() {
- cd "${srcdir}/PolyMC"
- mkdir -p build
- cd build
- cmake -DCMAKE_BUILD_TYPE=Release \
+ cmake -DCMAKE_BUILD_TYPE= \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DLauncher_APP_BINARY_NAME="${_pkgname}" \
- ..
- cmake --build .
+ -DLauncher_QT_VERSION_MAJOR=5 \
+ -Bbuild -SPolyMC
+ cmake --build build
}
check() {
- cd "${srcdir}/PolyMC/build"
+ cd "build"
ctest .
}
package() {
- cd "${srcdir}/PolyMC/build"
+ cd "build"
DESTDIR="$pkgdir" cmake --install .
}