summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcharlie52015-07-29 00:13:41 +1000
committercharlie52015-07-29 00:13:41 +1000
commit71e1bc83589b66e99a39e099ce932bb0f3f4d7a2 (patch)
tree284592ac68451f88748db27581eedd12981f49e9 /PKGBUILD
downloadaur-71e1bc83589b66e99a39e099ce932bb0f3f4d7a2.tar.gz
Initial import.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..083023935e07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
+
+pkgname=polyorb
+pkgver=2014
+pkgrel=1
+pkgdesc="PolyOrb provides the Distributed Systems Annex (DSA) to build distributed applications with Ada."
+
+arch=('i686' 'x86_64')
+url="http://libre.adacore.com/libre/tools/polyorb"
+license=('GPL')
+depends=("gcc-ada")
+makedepends=("nawk")
+
+source=(http://downloads.dragonlace.net/src/$pkgname-gpl-$pkgver-src.tar.gz
+ patch-Makefile.in)
+
+md5sums=('39df6ccf2d0dd19b250ba662b0b1dc4d'
+ 'c8142456832b10c7a06343e08ffde222')
+
+
+build() {
+
+ cd $srcdir/$pkgname-$pkgver-src
+
+ patch -p0 -i ../patch-Makefile.in
+
+ ./configure --prefix=/usr --with-appli-perso="dsa" --with-proto-perso="giop"
+ make
+}
+
+
+package() {
+ cd $srcdir/$pkgname-$pkgver-src
+
+ DESTDIR=$pkgdir make install
+}