summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Sampson2015-06-21 20:03:52 +1000
committerMike Sampson2015-06-21 20:03:52 +1000
commit00eaa1c4955b96d803a60f5664e13e0ffcd12c77 (patch)
tree89f0bbe68da24cbe3f39b91c4ff5737e3aeb144a /PKGBUILD
downloadaur-00eaa1c4955b96d803a60f5664e13e0ffcd12c77.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f51460bc265c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mike Sampson <mike at sambodata dot com>
+pkgname=polysh
+pkgver=0.4
+pkgrel=1
+pkgdesc="a tool to aggregate several remote shells into one."
+arch=('any')
+url="http://guichaz.free.fr/polysh/"
+license=('GPL2')
+depends=('python2')
+options=(!emptydirs)
+source=("http://guichaz.free.fr/polysh/files/polysh-0.4.tar.bz2")
+md5sums=('1d267caad5398b841c36d8c68b883a29')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's|env python|env python2|' polysh.py
+ sed -i -e 's|env python|env python2|' polysh/rb_tree.py
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ chmod 644 "$pkgdir/usr/share/man/man1/polysh.1"
+}
+
+# vim:set ts=2 sw=2 et: