summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikhail f. Shiryaev2018-09-02 22:52:16 +0200
committerMikhail f. Shiryaev2018-09-02 22:52:16 +0200
commitfa721b140c46d53aa23ebbd20555cd01aa4b3bef (patch)
tree6b700a8c585352d2c211d2b81bee7df01a5912de /PKGBUILD
parent483105dadedceb2ecbc5e7fba70bf58fd108bd1a (diff)
downloadaur-fa721b140c46d53aa23ebbd20555cd01aa4b3bef.tar.gz
Fix package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68ae3d86ed2..ea79978945a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,24 +9,24 @@
pkgname=polysh
pkgver=0.9
-pkgrel=2
-pkgdesc="This is a deprecated package. You have to use python-polysh"
+pkgrel=3
+pkgdesc="a tool to aggregate several remote shells into one."
arch=("any")
-url="https://pypi.org/project/polysh/"
+url="https://pypi.org/project/${pkgname}/"
license=("GPL2")
depends=("python" "openssh")
makedepends=("python-setuptools" "python-docutils")
options=(!emptydirs)
-source=("https://github.com/innogames/polysh/archive/polysh-${pkgver}.tar.gz")
+source=("https://github.com/innogames/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz")
sha256sums=("3f45061ad42fd9402fe6629e72e9f3d9f94b9f0b1401e76c3c1f69dcc713d2da")
package() {
- mkdir -p "${pkgdir}/usr/bin"
- cat > "${pkgdir}/usr/bin/polysh" <<EOF
-#!/usr/bin/python
-print('The "polysh" package is deprecated. Please, install "python-polysh" from AUR')
-EOF
- chmod +x "${pkgdir}/usr/bin/polysh"
+ # TODO: fix in upstream
+ cd "${srcdir}/${_basename}-${_basename}-${pkgver}"
+ # TODO: implement proper documentation in upstream
+ mkdir -p "${pkgdir}/usr/share/man/man1"
+ rst2man README.rst "${pkgdir}/usr/share/man/man1/${_basename}.1"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}
# vim:set ts=2 sw=2 et: