summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMilo Gilad2019-01-06 12:24:46 -0500
committerMilo Gilad2019-01-06 12:24:46 -0500
commit62877bdd8eb5dffa9616e97425bc8e4e253abd97 (patch)
treeff7762bc097fc3254a65739f2baa87a3e3f07947 /PKGBUILD
downloadaur-62877bdd8eb5dffa9616e97425bc8e4e253abd97.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b91644387f9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=pomo
+pkgver=0.6.0
+pkgrel=1
+epoch=
+pkgdesc="Pomodoro CLI"
+arch=(x86_64)
+url="https://kevinschoon.github.io/pomo"
+license=('MIT')
+makedepends=(go)
+source=("https://github.com/kevinschoon/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-linux-amd64")
+md5sums=("97be4ccf66c4ae4e3e154f87b9bb0bf2")
+noextract=("$pkgname-$pkgver-linux-amd64")
+
+prepare() {
+ mv "$pkgname-$pkgver-linux-amd64" pomo
+ chmod +x pomo
+}
+
+package() {
+ install -d "${pkgdir}/usr/bin"
+ install pomo "${pkgdir}/usr/bin"
+}