summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormyself6002022-12-24 02:42:20 +0100
committermyself6002022-12-24 02:42:20 +0100
commit0472bce68f2a3ce8c72734f7d1c909f657dfa5c8 (patch)
treec882bc29603b71fcb634ac65222a1173577c4ffc /PKGBUILD
parent652c2528027e11fa20fbcebfa0164325a2319607 (diff)
downloadaur-0472bce68f2a3ce8c72734f7d1c909f657dfa5c8.tar.gz
Add manpages (this was unnecessary)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52a2a76b3b08..725e2c991a35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
pkgname=ponscripter
pkgver=v3.0.1
_pkgver=`curl -s https://api.github.com/repos/07th-mod/ponscripter-fork/releases/latest|grep tag_name|cut -d\" -f4`
-pkgrel=1
+pkgrel=2
pkgdesc="Fork of the Ponscripter visual novel engine to take advantage of SDL2 and improve Steam integration"
arch=(x86_64 aarch64)
url=https://github.com/07th-mod/ponscripter-fork
license=(GPL)
-depends=(sdl2_{image,mixer} smpeg2 freetype2)
+depends=(sdl2_{image,mixer} smpeg freetype2)
+makedepends=(xmlto docbook-xsl)
source=(git+https://github.com/07th-mod/ponscripter-fork.git#tag=$_pkgver)
md5sums=(SKIP)
pkgver(){
@@ -16,9 +17,12 @@ build(){
cd $pkgname-fork
./configure -with-external-sdl-mixer
make
+ sed -i 's/ *//;/^$/d' doc/*.[0-9] # fix indentation
+ A=doc/ponscr-ext.7;sed -i '219d;222,231d;'218r<(sed '287,323!d;287s/^d/D/' $A.xml) $A # fix ponscr-ext
}
package(){
cd $pkgname-fork
- install src/ponscr -Dt "$pkgdir"/usr/bin
+ make PREFIX="$pkgdir"/usr install
install BUGS CHANGES MANUAL README.md TODO -Dt "$pkgdir"/usr/share/doc/$pkgname
+ mv "$pkgdir"/usr/{man,share}
}