summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralex.theoto2015-08-14 11:04:45 +0300
committeralex.theoto2015-08-14 11:04:45 +0300
commit64869ec994526cf235507d4a92c0e5ec8b372098 (patch)
tree80418a2c5cf033be30978f9a92c4f868c99f97a0 /PKGBUILD
downloadaur-64869ec994526cf235507d4a92c0e5ec8b372098.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9abd4a93af91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Anton Larionov <diffident dot cat at gmail dot com>
+
+pkgname=ponscripter
+pkgver=20111009
+pkgrel=2
+pkgdesc="NScripter-style novel-game interpreter with an emphasis on supporting games in Western languages"
+arch=('i686' 'x86_64')
+url="http://onscripter.unclemion.com/"
+license=('GPL')
+depends=('sdl_mixer' 'sdl_image' 'freetype2' 'gcc-libs')
+# Dependency 'smpeg' 'bzip2' already satisfied
+source=(http://unclemion.com/dev/attachments/download/48/$pkgname-$pkgver-src.tar.bz2)
+md5sums=('52927f2a57abe430d86ff4ac05ab7960')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}-src"
+ sed -i "36i\#include <unistd.h>" ./src/AnimationInfo.h
+ ./configure --prefix=/usr --no-werror
+ make
+}
+
+package() {
+ install -D -m755 "${srcdir}/${pkgname}-${pkgver}-src/src/ponscr" "${pkgdir}/usr/bin/${pkgname}"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}-src"
+ install -m644 BUGS CHANGES INSTALL MANUAL README TODO "${pkgdir}/usr/share/doc/${pkgname}"
+}
+
+# vim:set ts=2 sw=2 et: