summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErikWallstrom2021-02-07 03:26:17 +0100
committerErikWallstrom2021-02-07 03:26:17 +0100
commit7253f0153be1547944d3fbae6919d0476dd1e81b (patch)
tree857dccc606546009012d85f41af70038be056a0c /PKGBUILD
parent7b615510e55d6d0a85a3924b1bdbb49025cd559c (diff)
downloadaur-pop-gtk-theme-git.tar.gz
fix some problems and fit in with the current Arch wiki guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f157fec15dc3..4ba882751aa4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Erik Wallström <erik.wallstrom@live.com>
pkgname=pop-gtk-theme-git
_pkgname=pop-gtk-theme
-pkgver=4.0.0.b2.r219.gd7e5e73b
+pkgver=5.3.1.r3.g5ab6f1e4
pkgrel=1
pkgdesc="A GTK+ theme for Pop!_OS"
arch=("any")
@@ -40,20 +40,18 @@ conflicts=("${_pkgname}")
source=("git+https://github.com/pop-os/gtk-theme.git")
sha256sums=("SKIP")
-build() {
- cd "gtk-theme"
- meson build && cd build
- ninja
+pkgver() {
+ cd "${srcdir}/gtk-theme"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- cd "gtk-theme"
- cd build
- DESTDIR="${pkgdir}" ninja install
+build() {
+ cd "${srcdir}/gtk-theme"
+ arch-meson build
+ meson compile -C build
}
-pkgver() {
- cd "gtk-theme"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+package() {
+ cd "${srcdir}/gtk-theme"
+ DESTDIR="${pkgdir}" meson install -C build
}
-