summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErik Wallström2017-05-10 12:17:52 +0200
committerErik Wallström2017-05-10 12:17:52 +0200
commitf6e7dc0c8d989386c91c6ceded1761decfbaf67b (patch)
tree33f9040acf9b527d9241b9aa5506c8dab8294fa2 /PKGBUILD
downloadaur-f6e7dc0c8d989386c91c6ceded1761decfbaf67b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce33b71520dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Erik Wallström <erik.wallstrom@live.com>
+pkgname=pop-icon-theme-git
+_pkgname=pop-icon-theme
+pkgver="r1002.2b96014fb"
+pkgrel=1
+pkgdesc="A free and open source SVG icon theme for Linux, based on Paper Icon Set and Papirus."
+arch=("any")
+url="https://github.com/system76/pop-icon-theme"
+license=('GPL2' 'CCPL')
+makedepends=("git")
+optdepends=(
+ "gnome-shell>=3.18.3"
+ "gnome-flashback>=3.18.2"
+ "budgie-desktop>=10.2.7"
+ "xfce4-session>=4.12.2"
+ "mate-desktop>=1.14.0"
+ "mate-desktop>=1.14.0"
+ "lxde-common>=0.99.1"
+ "pop-gtk-theme-git: Recommended gtk theme"
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/system76/pop-icon-theme.git")
+sha256sums=("SKIP")
+
+#build() { }
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" post-install
+}
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}