summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Santini2024-02-25 22:19:50 +0100
committerGiovanni Santini2024-02-25 22:19:50 +0100
commit9c13e4f3383e271b96fe2d09bd91e035e86a7500 (patch)
treec6171f4b93e3916d566ee3f4959a01a15cfc293e /PKGBUILD
parent9e420ff372a20f67b8707055de0ba179c1388de5 (diff)
downloadaur-popcorntime.tar.gz
upgpkg: popcorntime 0.5.0-2
- Fix file permissions, make the app to work - Improve PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cebaa4f8682f..02c3daa706d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=popcorntime
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=(i686 x86_64)
url="https://popcorn-time.site/"
@@ -55,7 +55,7 @@ prepare() {
# Some dependencies in the yarn.lock file use "git+ssh", which is unavailable.
# Use "git+https" instead.
- echo "--> Apply Gulpfile fixes ..."
+ echo "--> Apply Yarn lockfile fixes ..."
git apply "$srcdir/yarn_lock-fixes.patch"
# Thanks to Eschwartz for the tip! yarn edition
@@ -70,18 +70,18 @@ prepare() {
echo "--> Installing normal dependencies"
yarn install
- echo "-->Install missing dependencies, if any ..."
+ echo "--> Install missing dependencies, if any ..."
# Here specific version of the packages will be installed
for package in $_missing_deps
do
- echo "-->Installing missing dependency $package"
+ echo "--> Installing missing dependency $package"
yarn install "$package"
done
# Change NW.js version, if defined
if [ -n "$_nwjs" ]
then
- echo "-->Changing NW.js version to $_nwjs ..."
+ echo "--> Changing NW.js version to $_nwjs ..."
sed -i "s|\(const nwVersion = '\)[0-9.]\+|\1$_nwjs|" gulpfile.js
fi
}
@@ -96,17 +96,23 @@ build() {
}
package() {
+ echo "--> Create required directories ..."
cd "${srcdir}/${_bpath}"
mkdir -p "${pkgdir}/usr/share/${pkgname}"
mkdir -p "${pkgdir}/usr/bin"
- cp -a . "${pkgdir}/usr/share/${pkgname}"
+ echo "--> Fix permissions of the package files ..."
+ find -type f -perm -u+r -exec chmod a+r {} \;
+ find -type f -perm -u+x -exec chmod a+x {} \;
- install -Dm644 "${srcdir}/${_srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/pixmaps/popcorntime.png"
- chmod +x "${pkgdir}/usr/share/${pkgname}/Popcorn-Time"
+ echo "--> Installing required files ..."
+ cp -a . "${pkgdir}/usr/share/${pkgname}"
+ echo "--> Create symlink in \$PATH ..."
ln -s "/usr/share/${pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${pkgname}"
+ echo "--> Install .destkop file ..."
+ install -Dm644 "${srcdir}/${_srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/pixmaps/popcorntime.png"
install -Dm644 "${srcdir}/popcorntime.desktop" "${pkgdir}/usr/share/applications/popcorntime.desktop"
}