summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Santini2017-05-24 17:12:05 +0200
committerGiovanni Santini2017-05-24 17:12:05 +0200
commit46fd12681eaafe603351dc7f75088bd74601a728 (patch)
tree80ad46efdbf4e49ccf3707a046e4b711dbf0c5a3 /PKGBUILD
parentb5a12d6cce87a0beb2d0f6db5b2a5477997acba2 (diff)
downloadaur-46fd12681eaafe603351dc7f75088bd74601a728.tar.gz
upgpkg: popcorntime 0.3.10-2
- Avoid security issue caused by subtitles - Fix broken build caused by the module 'thepiratebay'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 415a99d3a15c..36ea48727eef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=popcorntime
pkgver=0.3.10
-pkgrel=1
+pkgrel=2
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=('i686' 'x86_64')
url="http://popcorntime.sh/"
@@ -34,7 +34,7 @@ optdepends=('net-tools: vpn.ht client')
options=('!strip')
#install="popcorntime.install"
# Needed variables for sources downloads
-_commit_hash="tag=0.3.10"
+_commit_hash="commit=9e25e9f004bcab070cdecb201ba89da539b2f780"
_pkgname="popcorn-desktop"
source=(
@@ -54,13 +54,24 @@ _bpath="${_srcdir}/build/Popcorn-Time/${_platform}"
prepare() {
cd "${srcdir}/${_srcdir}"
- msg2 "Installing npm and bower dependencies..."
+ msg2 "Installing npm, bower and missing dependencies..."
# Using a different folder for the cache, makes the system cleaner
_cache=`npm config get cache`
npm config set cache "$srcdir/npm_cache"
+ msg2 "Cache changed from $_cache to `npm config get cache`"
+
+ msg2 "Install missing dependencies"
+ missing_ones="thepiratebay@1.4.0"
+ for package in $missing_ones
+ do
+ msg2 "Installing missing dependency $package"
+ npm install "$package"
+ done
+
# Actually install the stuff
- msg2 "Cache changed from $_cache to `npm config get cache`, ready to install"
+ msg2 "Installing normal dependencies"
npm install #-dd install
+
# Restore the cache directory
npm config set cache ${_cache}
}