summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Santini2016-12-01 21:18:39 +0100
committerGiovanni Santini2016-12-01 21:18:39 +0100
commitb5a12d6cce87a0beb2d0f6db5b2a5477997acba2 (patch)
tree6c5dff462a59d48e1a5e98bf6dcb9bbe26d6d093 /PKGBUILD
parent5fd84a77e039f751d1f765145b6bc21c264067f6 (diff)
downloadaur-b5a12d6cce87a0beb2d0f6db5b2a5477997acba2.tar.gz
upgpkg: popcorntime 0.3.10-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af4c2d506215..415a99d3a15c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
# Contributor: Ricardo Band <me [at] xengi [dot] de>
pkgname=popcorntime
-pkgver=0.3.9
-pkgrel=5
+pkgver=0.3.10
+pkgrel=1
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=('i686' 'x86_64')
url="http://popcorntime.sh/"
@@ -34,10 +34,11 @@ optdepends=('net-tools: vpn.ht client')
options=('!strip')
#install="popcorntime.install"
# Needed variables for sources downloads
-_commit_hash="65fc7c322bf92c5b526c1c1042e87ce0d0e6e085"
+_commit_hash="tag=0.3.10"
+
_pkgname="popcorn-desktop"
source=(
- "${_pkgname}_${pkgver}::git+https://github.com/popcorn-official/popcorn-desktop/#commit=${_commit_hash}"
+ "${_pkgname}_${pkgver}::git+https://github.com/popcorn-official/popcorn-desktop/#${_commit_hash}"
"popcorntime.desktop"
)
sha256sums=('SKIP'
@@ -54,10 +55,14 @@ prepare() {
cd "${srcdir}/${_srcdir}"
msg2 "Installing npm and bower dependencies..."
- npm install
-
- msg2 "Fixing wrong gulp installation issue..."
- npm install gulp
+ # Using a different folder for the cache, makes the system cleaner
+ _cache=`npm config get cache`
+ npm config set cache "$srcdir/npm_cache"
+ # Actually install the stuff
+ msg2 "Cache changed from $_cache to `npm config get cache`, ready to install"
+ npm install #-dd install
+ # Restore the cache directory
+ npm config set cache ${_cache}
}
build() {