summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Santini2018-09-06 19:20:09 +0200
committerGiovanni Santini2018-09-06 19:20:09 +0200
commitff915a5633e69cf8f2a2179d1941dc68536b5fc2 (patch)
treecf2502750857451059e2316dd1fc7843b226f369 /PKGBUILD
parent98341644948ff87d19fad6aba56f24a412a5771b (diff)
downloadaur-ff915a5633e69cf8f2a2179d1941dc68536b5fc2.tar.gz
upgpkg: popcorntime 0.3.10-12
- Switch back to nw.js 0.31.5 Tested all the 0.32.x versions, but none is working - Small adjustments PKGBUILD looks better
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d5e6e83c7d3..a6903f9b1347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=popcorntime
pkgver=0.3.10
-pkgrel=11
+pkgrel=12
pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
arch=('i686' 'x86_64')
url="https://popcorntime.sh/"
@@ -25,7 +25,7 @@ _commit_hash="commit=be800aa98cb9ef16f7e00737bbc51ba69204ed8f"
_pkgname="popcorn-desktop"
# Useful variables for builds
-_nwjs="0.32.3"
+_nwjs="0.31.5"
[ "$CARCH" = "i686" ] && _platform=linux32
[ "$CARCH" = "x86_64" ] && _platform=linux64
_srcdir="${_pkgname}"
@@ -46,8 +46,8 @@ source_x86_64=("https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/downloa
sha256sums=('SKIP'
'fa2615680bcb591b9892e8d6394235436ffa65210be6e942b8ca91de982e8cd2'
'4422f21e16176fda697ed0c8a6d1fb6f9dd7c4bc3f3694f9bcc19cbe66630334')
-sha256sums_i686=('ab90d8c157abe8156bc0a1503cda8a52eb006eb5c7a664e22c6f006b1f3d76e1')
-sha256sums_x86_64=('4aebfb88ca4efd80672fd94528af51021f7e792637fbe0e5401f8a4ab07c74f2')
+sha256sums_i686=('78241eb9e051dff300ea310c7fb44093cd242be9f88e7659b0db991f378adbc3')
+sha256sums_x86_64=('c7f4620cd51f3df1a573c84f42e57a575d320788730693b157a52115b73f3edc')
# Building the package
prepare() {
@@ -80,9 +80,9 @@ prepare() {
done
# Use upstream nw.js, to avoid possible binary malware
- sed -i "s|get.popcorntime.sh/repo/nw|dl.nwjs.io|" gulpfile.js
+ sed -i "s|get.popcorntime.sh/repo/nw|dl.nwjs.io|" gulpfile.js
# And use latest version of nw.js
- sed -i "s|\(const nwVersion = '\)[0-9.]\+|\1$_nwjs|" gulpfile.js
+ sed -i "s|\(const nwVersion = '\)[0-9.]\+|\1$_nwjs|" gulpfile.js
# Fix problems with the dependecies list function with newer npm versions
patch -Np1 -i "$srcdir/gulp-fixes.patch"
}