summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFirstAirBender2020-03-18 11:23:32 -0600
committerFirstAirBender2020-03-18 11:23:32 -0600
commit1e46e465cb6a3797e507d3ae35bd2c564887415b (patch)
tree0e32b9daf01124b2b1a7c4b357d31d3b8c9e16db /PKGBUILD
parent2588ac7703dc97a38eabc5e25625dcda1c1b4703 (diff)
downloadaur-1e46e465cb6a3797e507d3ae35bd2c564887415b.tar.gz
update desktop file and fix conflicts option in pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b178e85cd46..b81faabd2b2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,9 @@
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
+# https://jlk.fjfi.cvut.cz/arch/manpages/man/PKGBUILD.5
pkgname=popcorntime-git
-pkgver=v0.4.0+r6483+g5c68847e
+pkgver=v0.4.0+r6485+g597a9871
pkgrel=1
pkgdesc='Popcorn Time is a multi-platform, free software BitTorrent client that includes an integrated media player.'
arch=(i686 x86_64)
@@ -14,23 +15,18 @@ license=(GPL3)
depends=(gtk3 libxss nss nodejs)
makedepends=(git yarn npm)
provides=(popcorntime)
-conflicts=(popcorntime popcorntime-ce)
-options=(!strip)
+conflicts=(popcorntime popcorntime-bin)
+options=(!emptydirs)
source=(git+https://github.com/popcorn-official/popcorn-desktop#branch=development
popcorntime.desktop)
sha512sums=('SKIP'
- 'abf5d406467422168944244b95eac0d2c23ca4140cd803afeea852e9a15a5176a019a5772be919234fe01ceec0d8d135158900e828144b0079018015662f7dcd')
+ '81a447cd3365b439964c1b9eba14bcf31de05e62123ce032590ac2109a447c5db0306bf4c593fe30f075d2b3674a1611a81b7554e43acba152ef34652c819a33')
pkgver() {
cd popcorn-desktop
- echo $(git describe --abbrev=0)+r$(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)
+ echo "$(git describe --abbrev=0)+r$(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)"
}
-# prepare() {
-# cd popcorn-desktop
-# patch -p1 --binary < "$srcdir/nwjs-patch.diff"
-# }
-
build() {
cd popcorn-desktop
yarn config set yarn-offline-mirror ./node_modules/
@@ -38,6 +34,7 @@ build() {
yarn build
}
+# https://wiki.archlinux.org/index.php/creating_packages
package() {
cd popcorn-desktop
@@ -47,10 +44,13 @@ package() {
"$pkgdir/usr/share/popcorntime"
# Fix file permissions
- find "$pkgdir/usr/share/popcorntime" -type f -not -name Popcorn-Time -exec chmod 644 {} +
+ find "$pkgdir/usr/share/popcorntime" -type f -not -name 'Popcorn-Time' -exec chmod 644 {} +
+ find "$pkgdir/usr/share/popcorntime" -type d -exec chmod 755 {} +
- ln -s /usr/share/popcorntime/Popcorn-Time "$pkgdir"/usr/bin/popcorntime
+ # Symlink binary to /usr/bin/popcorntime
+ # See: https://bbs.archlinux.org/viewtopic.php?id=143970
+ ln -sv /usr/share/popcorntime/Popcorn-Time "$pkgdir/usr/bin/popcorntime"
- install -Dm 644 ../popcorntime.desktop -t "$pkgdir"/usr/share/applications
- install -Dm 644 src/app/images/icon.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/popcorntime.png
+ install -Dm 644 "$srcdir/popcorntime.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm 644 src/app/images/icon.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/popcorntime.png"
}