summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2017-01-31 20:03:11 +0100
committerPieter Goetschalckx2017-01-31 20:03:11 +0100
commit371ecac68f27ff23f492eaf8d8e3f6b6e3245270 (patch)
treeb6ce7c36d55da1ad8a9842b3be9c4802117a4e28 /PKGBUILD
parent0fc7acb8666981600155d2a9aba0dddb7057de52 (diff)
downloadaur-371ecac68f27ff23f492eaf8d8e3f6b6e3245270.tar.gz
Update dependencies and make executable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06cd2c307da1..95af7338de22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgname=popcorntime-git
_pkgname=popcorntime
_gitname=popcorn-desktop
-pkgver=r6157.5aabb4b
+pkgver=r6211.db796345
pkgrel=1
pkgdesc="Stream movies and TV shows from torrents"
arch=('i686' 'x86_64')
url="https://popcorntime.sh"
license=('GPL3')
-depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify' 'desktop-file-utils')
-makedepends=('git' 'npm' 'bower' 'nodejs-grunt-cli' 'gulp')
+depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify')
+makedepends=('git' 'npm')
conflicts=('popcorntime' 'popcorn-time-ce')
provides=('popcorntime')
options=('!strip')
@@ -29,14 +29,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${_gitname}"
- npm install
-}
-
build() {
cd "${_gitname}"
- gulp build -p ${_platform}
+
+ npm install
+ node_modules/.bin/gulp build --platforms ${_platform}
}
package() {
@@ -56,4 +53,5 @@ package() {
# Copy complete content of source archive to /usr/share/${_pkgname}/
cp -a "${_bpath}"/* "${pkgdir}/usr/share/${_pkgname}/"
+ chmod +x "${pkgdir}/usr/share/${_pkgname}/Popcorn-Time"
}