summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2018-07-30 14:48:29 -0400
committerJean Lucas2018-07-30 14:49:54 -0400
commit3ca6faddedaa33c96421a602ddb68e88102cfb64 (patch)
tree150d74d1a509857efd66a292c8185e01cf6329be /PKGBUILD
parent1b29ee02710b35db2662759a79ce1a90f42de222 (diff)
downloadaur-3ca6faddedaa33c96421a602ddb68e88102cfb64.tar.gz
Add arch-specific source arrays, remove redundant variables
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c41df57223c7..02328ae92843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,16 +17,18 @@ makedepends=(git)
provides=(popcorntime)
conflicts=(popcorntime popcorntime-ce)
options=(!strip)
-[ "$CARCH" = i686 ] && _arch=x86 _platform=linux32 _nwjsffmpegarch=ia32
-[ "$CARCH" = x86_64 ] && _arch=x64 _platform=linux64 _nwjsffmpegarch=x64
-_node=node-v$_nodever-linux-$_arch
-_nwjssdk=nwjs-sdk-v$_nwjsver-linux-$_nwjsffmpegarch
-_nwjsffmpeg=$_nwjsver-linux-$_nwjsffmpegarch
-source=(git+https://github.com/popcorn-official/popcorn-desktop#branch=development
- https://nodejs.org/dist/v$_nodever/$_node.tar.xz
- https://dl.nwjs.io/v$_nwjsver/$_nwjssdk.tar.gz
- https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/download/$_nwjsver/$_nwjsffmpeg.zip)
-sha512sums=(SKIP
+source=(git+https://github.com/popcorn-official/popcorn-desktop#branch=development)
+source_i686=(https://nodejs.org/dist/v$_nodever/node-v$_nodever-linux-x86.tar.xz
+ https://dl.nwjs.io/v$_nwjsver/nwjs-sdk-v$_nwjsver-linux-ia32.tar.gz
+ https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/download/$_nwjsver/$_nwjsver-linux-ia32.zip)
+source_x86_64=(https://nodejs.org/dist/v$_nodever/node-v$_nodever-linux-x64.tar.xz
+ https://dl.nwjs.io/v$_nwjsver/nwjs-sdk-v$_nwjsver-linux-x64.tar.gz
+ https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/download/$_nwjsver/$_nwjsver-linux-x64.zip)
+sha512sums=(SKIP)
+sha512sums_i686=(609b2e149ac59082a520719f95e703b6b45b8ce21897fe4f4fa4571c6030a6945f1324582b9a708a8e2b42947fae40584e29d6b3214c210a70c2869f4fd8d6f4
+ 458da696d702afa450cde3371b0ca87ac99a323a27ad9e304eb4a06af008f1a7d20cfeb11e4005716da1506ec28fe222679ad228f856f844ed516b7d2e7cea88
+ 5435d42244a6dc8b5f11a556fe45991ff64058de8ec55c63f18a837b9bc7a2bb9ec1eac08c2876225b83c22e6478a71599eb30d517cc6261c948b4b579a36573)
+sha512sums_x86_64=(
c727809867ea727e6fbdbd0ed7fcc6ce1a755f38625b1296bdf54a7fd38e5d9b5f8c5c48e7208ed5cdaaa910a36eb5d19b2f95ee3c5ee35e717e76dcc6de6b40
863a99a04f547ef9ca6030ed98954ffaee4009c995d8b99be23d0895e09786fd4debb5946d38cf625c87d567738b8271848500391740fd99de6678818741a615
669fae5f220d1508187c29c05d4af46033df29ad053dfecd95dd776df36095b1fff9aee9b2f4271908bf899e57ae75357059af46175353385b1b0561ee15ab72)
@@ -41,15 +43,18 @@ prepare() {
sed -i s#get.popcorntime.sh/repo/nw#dl.nwjs.io# popcorn-desktop/gulpfile.js
}
+[ "$CARCH" = i686 ] && _arch=x86 _platform=linux32 _nwjsffmpegarch=ia32
+[ "$CARCH" = x86_64 ] && _arch=x64 _platform=linux64 _nwjsffmpegarch=x64
+
build() {
msg2 'Using temporary Node.js toolchain...'
- PATH=$PWD/$_node/bin:$PWD/popcorn-desktop/node_modules/.bin:$PATH
+ PATH=$PWD/node-v$_nodever-linux-$_arch/bin:$PWD/popcorn-desktop/node_modules/.bin:$PATH
npm_config_cache=$PWD/npm_cache
cd popcorn-desktop
npm install
_cache=cache/$_nwjsver-sdk/$_platform
mkdir -p $_cache
- cp -a ../$_nwjssdk/* $_cache
+ cp -a ../nwjs-sdk-v$_nwjsver-linux-$_nwjsffmpegarch/* $_cache
gulp build
}