summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2016-02-19 16:26:08 +0100
committerPieter Goetschalckx2016-02-19 16:26:08 +0100
commit45c311723c9ba1fb75421aed1476dbda662cce27 (patch)
tree3aafb11246b162f703729a182a2def4b4ab1e5d5 /PKGBUILD
parentee76a249f6490c5efbbee0f9e068e1fe88840f61 (diff)
downloadaur-45c311723c9ba1fb75421aed1476dbda662cce27.tar.gz
Don't zip
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e3b1d356f8f..b9d372c3faa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+# Maintainer: Pieter Goetschalckx <3.14.e.ter [at] gmail [dot] com>
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
@@ -11,9 +11,9 @@ pkgdesc="Stream movies and TV shows from torrents"
arch=('i686' 'x86_64')
url="https://popcorntime.sh"
license=('GPL3')
-depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst')
+depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst' 'libnotify' 'desktop-file-utils')
makedepends=('git' 'nodejs-grunt-cli' 'bower' 'npm')
-conflicts=('popcorntime')
+conflicts=('popcorntime' 'popcorn-time-ce')
provides=('popcorntime')
options=('!strip')
install=popcorntime.install
@@ -32,7 +32,6 @@ pkgver() {
prepare() {
cd "${_gitname}"
- sed "s/zip: false/zip: true/g" -i gulpfile.js
npm install
}
@@ -45,15 +44,16 @@ build() {
package() {
_bpath="${_gitname}/build/Popcorn-Time/${_platform}"
- install -d "${pkgdir}/usr/share/${_pkgname}"
- install -d "${pkgdir}/usr/share/${_pkgname}/locales"
- install -d "${pkgdir}/usr/bin"
+ install -dm755 "${pkgdir}/usr/share/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
# Program
install -Dm755 "${_bpath}/Popcorn-Time" "${pkgdir}/usr/share/${_pkgname}/"
- install -Dm644 "${_bpath}/"{nw.pak,libffmpegsumo.so,icudtl.dat} "${pkgdir}/usr/share/${_pkgname}/"
- install -Dm644 "${_bpath}/locales/"*.pak "${pkgdir}/usr/share/${_pkgname}/locales/"
+ install -Dm644 "${_bpath}/"{icudtl.dat,libffmpegsumo.so,nw.pak,package.json} \
+ "${pkgdir}/usr/share/${_pkgname}/"
+ # Directories
+ cp -a "${_bpath}/"{locales,node_modules,src} "${pkgdir}/usr/share/${_pkgname}/"
# Link to program
ln -s "/usr/share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}"
@@ -62,7 +62,7 @@ package() {
install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
# Icon
- install -Dm644 "${_gitname}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
+ install -Dm644 "${_bpath}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
}
# vim:set ts=2 sw=2 et: