summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2018-07-21 14:56:24 -0400
committerJean Lucas2018-07-21 16:42:25 -0400
commitbd90edc1d66fcb59b0d3377d9b24903ffc33e2cd (patch)
treec8fd0a80d16f110101efd6e365a94e1aa24f6fb6 /PKGBUILD
parent854305bc24b19b17025078946b691667b325dc68 (diff)
downloadaur-bd90edc1d66fcb59b0d3377d9b24903ffc33e2cd.tar.gz
Use upstream NW.js instead of downstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cffc0caa450..e72ae5bc049f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=popcorntime-git
_pkgname=popcorntime
_gitname=popcorn-desktop
pkgver=0.3.10+6288+be800aa9
-pkgrel=1
+pkgrel=2
pkgdesc='Stream movies and TV shows from torrents'
arch=(i686 x86_64)
url=https://popcorntime.sh
@@ -24,24 +24,23 @@ sha512sums=(SKIP
pkgver() {
cd $_gitname
- printf $(git tag)+$(git rev-list --count HEAD)+$(git rev-parse --short HEAD)
+ echo $(git tag)+$(git rev-list --count HEAD)+$(git rev-parse --short HEAD)
}
-#prepare() {
-# cd $_gitname
-# msg2 'Using upstream NW.js instead of downstream one...'
-# sed -i s#get.popcorntime.sh/repo/nw#dl.nwjs.io# gulpfile.js
-#}
+prepare() {
+ msg2 'Using upstream NW.js instead of downstream...'
+ sed -i s#get.popcorntime.sh/repo/nw#dl.nwjs.io# $_gitname/gulpfile.js
+}
[ "$CARCH" = i686 ] && _arch=x86 _platform=linux32
[ "$CARCH" = x86_64 ] && _arch=x64 _platform=linux64
build() {
msg2 'Using temporary Node.js toolchain...'
- _nodever=v6.14.3
- _node=node-$_nodever-linux-$_arch
- [ -f $_node.tar.xz ] || wget https://nodejs.org/dist/$_nodever/$_node.tar.xz
- tar xfp node-$_nodever-linux-$_arch.tar.xz
+ _nodever=6.14.3
+ _node=node-v$_nodever-linux-$_arch
+ [ -f $_node.tar.xz ] || wget https://nodejs.org/dist/v$_nodever/$_node.tar.xz
+ tar xfp $_node.tar.xz
export PATH=$PWD/$_node/bin:$PWD/$_gitname/node_modules/.bin:$PATH
export npm_config_cache=$PWD/npm_cache
cd $_gitname
@@ -50,10 +49,10 @@ build() {
}
package() {
- install -d $pkgdir/usr/{share/$_pkgname,bin}
install -Dm 644 $_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
cd $_gitname/build/Popcorn-Time/$_platform
install -Dm 644 src/app/images/icon.png $pkgdir/usr/share/icons/hicolor/256x256/apps/$_pkgname.png
+ install -d $pkgdir/usr/{share/$_pkgname,bin}
cp -a . $pkgdir/usr/share/$_pkgname
cd $pkgdir/usr/share/$_pkgname
find . -type f -exec chmod -R +r,-x {} +