summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2016-02-19 15:55:34 +0100
committerPieter Goetschalckx2016-02-19 15:55:34 +0100
commitee76a249f6490c5efbbee0f9e068e1fe88840f61 (patch)
tree346fb2b5093ebb9f7d6dff8acee84d38317a1582 /PKGBUILD
parentdc06f40d292e7265ec60a050f6052b59384821c6 (diff)
downloadaur-ee76a249f6490c5efbbee0f9e068e1fe88840f61.tar.gz
Update for new release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 27 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c367c7b6563f..7e3b1d356f8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,78 +1,68 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
pkgname=popcorntime-git
-pkgver=r5335.da86004
+_pkgname=popcorntime
+_gitname=popcorn-desktop
+pkgver=r5792.8c5a48a
pkgrel=1
-pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch."
+pkgdesc="Stream movies and TV shows from torrents"
arch=('i686' 'x86_64')
-url="http://popcorntime.io"
+url="https://popcorntime.sh"
license=('GPL3')
depends=('alsa-lib' 'gconf' 'gtk2' 'nss' 'ttf-font' 'libxtst')
-optdepends=('net-tools: vpn.ht client')
makedepends=('git' 'nodejs-grunt-cli' 'bower' 'npm')
conflicts=('popcorntime')
provides=('popcorntime')
options=('!strip')
-install="popcorntime.install"
+install=popcorntime.install
+source=("git+https://github.com/popcorn-official/${_gitname}.git"
+ "${_pkgname}.desktop")
+sha256sums=('SKIP'
+ '7e22d234a2e7dd1e632e094154c44b31be7f93962df93dd865f3775b8e644c05')
[ "$CARCH" = "i686" ] && _platform=linux32
[ "$CARCH" = "x86_64" ] && _platform=linux64
-_gitname=desktop
-_nw_ver=0.12.2
-
-source=('popcorntime.install'
- "git+https://git.popcorntime.io/popcorntime/desktop.git"
- "popcorntime.desktop")
-md5sums=('efe872f41ed74a706308b4015e4fd82f'
- 'SKIP'
- '9608f35f4cc083a0c36b0f4ef275ab10')
pkgver() {
- cd "${srcdir}/${_gitname}"
+ cd "${_gitname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}/${_gitname}"
-
- export PYTHON=/usr/bin/python2
-
- # Get dependencies
+ cd "${_gitname}"
+ sed "s/zip: false/zip: true/g" -i gulpfile.js
npm install
}
build() {
- cd "${srcdir}/${_gitname}"
-
- # FIXME: fails the first time:
- # Fatal error: Cannot read property 'length' of undefined
- grunt build || grunt build
+ cd "${_gitname}"
+ grunt build
+ gulp build
}
package() {
- cd "${srcdir}"
-
- _bpath="${srcdir}/${_gitname}/build/releases/Popcorn-Time/${_platform}/Popcorn-Time"
+ _bpath="${_gitname}/build/Popcorn-Time/${_platform}"
- install -d "${pkgdir}/usr/lib/popcorntime"
+ install -d "${pkgdir}/usr/share/${_pkgname}"
+ install -d "${pkgdir}/usr/share/${_pkgname}/locales"
install -d "${pkgdir}/usr/bin"
# Program
- install -Dm755 "${_bpath}/Popcorn-Time" "${pkgdir}/usr/lib/popcorntime/"
- install -Dm644 "${_bpath}/nw.pak" "${pkgdir}/usr/lib/popcorntime/"
- install -Dm644 "${_bpath}/libffmpegsumo.so" "${pkgdir}/usr/lib/popcorntime/"
- install -Dm644 "${srcdir}/${_gitname}/build/cache/${_platform}/${_nw_ver}/icudtl.dat" "${pkgdir}/usr/lib/popcorntime/"
+ install -Dm755 "${_bpath}/Popcorn-Time" "${pkgdir}/usr/share/${_pkgname}/"
+ install -Dm644 "${_bpath}/"{nw.pak,libffmpegsumo.so,icudtl.dat} "${pkgdir}/usr/share/${_pkgname}/"
+ install -Dm644 "${_bpath}/locales/"*.pak "${pkgdir}/usr/share/${_pkgname}/locales/"
+
# Link to program
- mkdir -p "${pkgdir}/usr/bin"
- ln -s "/usr/lib/popcorntime/Popcorn-Time" "${pkgdir}/usr/bin/popcorntime"
+ ln -s "/usr/share/${_pkgname}/Popcorn-Time" "${pkgdir}/usr/bin/${_pkgname}"
# Desktop file
- install -Dm644 "${srcdir}/popcorntime.desktop" "${pkgdir}/usr/share/applications/popcorntime.desktop"
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
# Icon
- install -Dm644 "${srcdir}/${_gitname}/src/app/images/icon.png" "${pkgdir}/usr/share/pixmaps/popcorntime.png"
+ install -Dm644 "${_gitname}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
}
# vim:set ts=2 sw=2 et: