summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFirstAirBender2020-03-15 17:06:33 -0600
committerFirstAirBender2020-03-15 17:06:33 -0600
commitee96bfa0030abe567567bcede99e1e102e925eb3 (patch)
tree032a63248e02c7b7be7589cf1ea58da38b189a3a /PKGBUILD
parent09d18ed6cb64942200b23ae186355cc36228df74 (diff)
downloadaur-ee96bfa0030abe567567bcede99e1e102e925eb3.tar.gz
remove nwjs patch as this has been fixed upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebf20884381e..d93d1f14903b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,31 @@
# Contributor: FirstAirBender <noblechuk5 [at] web [dot] de>
pkgname=popcorntime-git
-pkgver=0.3.10+r6429+g1537575b
+pkgver=0.3.10+r6475+gef48d491
pkgrel=1
-pkgdesc='BitTorrent client with integrated media player (git)'
+pkgdesc='Popcorn Time is a multi-platform, free software BitTorrent client that includes an integrated media player. Desktop ( Windows / Mac / Linux ) a Butter-Project Fork'
arch=(i686 x86_64)
-url=https://popcorntime.sh
+url=https://popcorntime.app
license=(GPL3)
-depends=(alsa-lib atk cairo gdk-pixbuf2 gtk3 libcups libx11 libxcb libxcomposite libxcursor libxdamage libxext libxfixes libxi libxrandr libxrender libxss libxtst nspr nss pango)
+depends=(gtk3 libxss nss nodejs)
makedepends=(git yarn npm)
provides=(popcorntime)
conflicts=(popcorntime popcorntime-ce)
options=(!strip)
source=(git+https://github.com/popcorn-official/popcorn-desktop#branch=development
- popcorntime.desktop
- nwjs-patch.diff)
+ popcorntime.desktop)
sha512sums=('SKIP'
- 'abf5d406467422168944244b95eac0d2c23ca4140cd803afeea852e9a15a5176a019a5772be919234fe01ceec0d8d135158900e828144b0079018015662f7dcd'
- '4749e7e521b0e784a956231baccb0841a0f28a7f7415d6e47f24ba3138e4fe88c2e6d9defcd10acbe86718a42a6b99dcbddaa20d95df584c71ad2ad653a180cf')
+ 'abf5d406467422168944244b95eac0d2c23ca4140cd803afeea852e9a15a5176a019a5772be919234fe01ceec0d8d135158900e828144b0079018015662f7dcd')
pkgver() {
cd popcorn-desktop
echo $(git tag)+r$(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)
}
-prepare() {
- cd popcorn-desktop
- patch -p1 --binary < "$srcdir/nwjs-patch.diff"
-}
+# prepare() {
+# cd popcorn-desktop
+# patch -p1 --binary < "$srcdir/nwjs-patch.diff"
+# }
build() {
cd popcorn-desktop
@@ -46,10 +44,10 @@ package() {
install -d "$pkgdir"/usr/{share,bin}
cp -a build/Popcorn-Time/$([ $CARCH = x86_64 ] && echo linux64 || echo linux32) \
- "$pkgdir"/usr/share/popcorntime
+ "$pkgdir/usr/share/popcorntime"
# Fix file permissions
- find "$pkgdir"/usr/share/popcorntime -type f -not -name Popcorn-Time -exec chmod 644 {} +
+ find "$pkgdir/usr/share/popcorntime" -type f -not -name Popcorn-Time -exec chmod 644 {} +
ln -s /usr/share/popcorntime/Popcorn-Time "$pkgdir"/usr/bin/popcorntime