summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorInvisible Fox2020-11-14 15:24:21 +0300
committerInvisible Fox2020-11-14 15:24:21 +0300
commit8d00dfb8fea0a34586e340bfe045b3d34fe947f7 (patch)
tree827cf67c2be35929b2f79a60eb348aa0b325f4ff /PKGBUILD
downloadaur-8d00dfb8fea0a34586e340bfe045b3d34fe947f7.tar.gz
Inital commit of v0.4.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e725a5d01cab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Gladyshev Ilya <fixfromdarkness@cock.li>
+
+pkgname=popcorntime-ru-bin
+_pkgname=popcorntime-ru
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="Stream free movies and TV shows from torrents with Russian translation"
+arch=('x86_64')
+url="https://popcorn-ru.tk"
+license=('GPL3')
+depends=('nss' 'ttf-font' 'libxss' 'gtk2' 'gtk3')
+makedepends=('unzip')
+provides=('popcorntime' 'popcorntime-ce')
+conflicts=()
+options=('!strip')
+_zipfile="Popcorn-Time-Ru-${pkgver}-linux64.zip"
+source=("https://github.com/popcorn-time-ru/popcorn-desktop/releases/download/v${pkgver}/${_zipfile}"
+ "${_pkgname}.desktop" )
+sha256sums=('5a890d792466f50151056ccf8c681bb809434da737fd27bb6efb9ab289b9e542'
+ '144dc8864d74abed5022b354ecd34b9a7bc6a0f0fdd442e0bac438c2ce6c4c5b')
+
+package() {
+ install -dm755 "${pkgdir}/usr/share/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+
+ # Link to program
+ ln -s "../share/${_pkgname}/Popcorn-Time-Ru" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Desktop file
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # Icon
+ install -Dm644 "${srcdir}/src/app/images/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${_pkgname}.png"
+
+ # Remove makepkg-created symlinks before copying content
+ rm "$_zipfile" "${_pkgname}.desktop"
+
+ # Copy complete content of source archive to /usr/share/${_pkgname}
+ cp -a "${srcdir}"/* "${pkgdir}/usr/share/${_pkgname}"
+
+ # Fix permissions
+ find "${pkgdir}/usr/share/${_pkgname}/" -perm 600 -exec chmod 644 '{}' \;
+ find "${pkgdir}/usr/share/${_pkgname}/" -perm 700 -exec chmod 755 '{}' \;
+}