summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2021-02-12 09:50:59 +0100
committerbartus2021-02-12 09:50:59 +0100
commit6a4528f71b844051b62d1f1e19c5754f70dfe6b5 (patch)
tree24d07f3156efd8a35bac150613f6c2ce21ed7522 /PKGBUILD
parentc68cfd50b718a422052daa12beeb6c94d4eec420 (diff)
downloadaur-6a4528f71b844051b62d1f1e19c5754f70dfe6b5.tar.gz
Pin cuda version in pacakge()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf8d0261d81e..5ab34e17c37b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ license=('MPL2')
groups=()
conflicts=()
provides=()
-makedepends=('boost' 'cmake' 'git')
+makedepends=('boost' 'cmake' 'git' 'expac')
makedepends+=('cuda>=7.0')
checkdepends=('wget')
source=("${_name}::git+https://github.com/alicevision/popsift.git")
@@ -51,7 +51,9 @@ build() {
package_popsift() {
pkgdesc+=" [development headers and static libs]"
- depends=('boost' "popsift-libs=${pkgver}")
+ _cuda_version=$(expac -Q '%v' cuda)
+ _cuda_version=${_cuda_version%-[0-9]*}
+ depends=('boost' "popsift-libs=${pkgver}" "cuda${_cuda_version:+=$_cuda_version}")
optdepend=('cuda: for static cudart library')
options=('staticlibs')
make -C "$srcdir/build_static" DESTDIR="${pkgdir}" install