summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWillem Mulder2023-08-30 12:38:04 +0200
committerWillem Mulder2023-08-30 12:38:22 +0200
commitfed8a2d429e8d69710dac267c7be660355d71894 (patch)
treed05032979676472ce5479a257a5d5a8a3fe97ff9 /PKGBUILD
parentaf988c64bc8ddfdb03588b70b5d6ff1a96539a19 (diff)
downloadaur-portage-git.tar.gz
Update PKGBUILD to reflect upstream's ebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8443bb4787d6..42977bd79650 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: robertfoster
pkgname=portage-git
-pkgver=3.0.49.r35.058613d54
+pkgver=3.0.51.r5.6d90cf039
pkgrel=1
pkgdesc="Gentoo's package management system "
url="http://www.gentoo.org/proj/en/portage/index.xml"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('python' 'xmlto' 'rsync' 'eselect-git')
-source=("${pkgname%-git}::git://anongit.gentoo.org/proj/portage.git")
+depends=('python' 'rsync' 'eselect-git')
+source=("git+https://anongit.gentoo.org/git/proj/portage.git")
sha384sums=('SKIP')
-makedepends=('epydoc' 'git' 'docbook-xsl')
+makedepends=('git' 'meson')
+checkdepends=('python-pytest')
install="${pkgname}.install"
pkgver() {
@@ -19,7 +20,7 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}"
- arch-meson . build
+ arch-meson . build -Dipc=true -Drsync-verify=false
meson compile -C build
}
@@ -30,5 +31,5 @@ package() {
check() {
cd "${srcdir}/${pkgname%-git}"
- meson test -C build
+ meson test -C build --no-rebuild --verbose
}