summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaultDon2015-07-02 10:44:46 -0700
committerSaultDon2015-07-02 10:44:46 -0700
commit473f43165f7af219470b6139cfa74d76359d3fd2 (patch)
tree524c7a4f44391fe42368a0bf0937ecaeb761d3b2 /PKGBUILD
downloadaur-473f43165f7af219470b6139cfa74d76359d3fd2.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e6903402427
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: SaultDon <sault.don gmail>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+# Contributor: William Rea <sillywilly@gmail.com>
+pkgname=postgis-sfcgal
+_pkgname=${pkgname%-sfcgal}
+pkgver=2.1.7
+pkgrel=1
+pkgdesc="Adds support for geographic objects to PostgreSQL and includes SFCGAL support for experimental 3D functions"
+arch=('i686' 'x86_64')
+url="http://postgis.net/"
+license=('GPL')
+depends=('postgresql' 'gdal' 'geos' 'json-c' 'cgal' 'sfcgal' 'libxml2' 'libxslt')
+changelog=$pkgname.changelog
+provides=("$_pkgname=$pkgver")
+conflicts=($_pkgname)
+source=("http://download.osgeo.org/postgis/source/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('00ab79a3f609d7ea458f6fc358032ad059cb720baf88285243d6436a597a7ec2')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+
+ ./autogen.sh
+ ./configure --prefix=/usr --with-raster --with-gdalconfig=/usr/bin/gdal-config --with-gui
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}