summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Arnhold2017-11-26 11:32:22 +0100
committerThomas Arnhold2017-11-26 11:32:22 +0100
commitc8af6470934ecf768735a72eb0de3a28bd66a6b4 (patch)
tree98a476091f2edc47dee481e41886d03fcbee6f5e /PKGBUILD
parent3362cf500405dbd938a57a3d66a9e9d1dbc2e3e1 (diff)
downloadaur-c8af6470934ecf768735a72eb0de3a28bd66a6b4.tar.gz
postgresql-9.6.6-2
Adopt to official postgresql-9.6.5 build script and build just everything including documentation.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6eaa06dc586c..8a6d74a3c2ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# Maintainer: Thomas Arnhold <thomas@arnhold.org
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Dan McGee <dan@archlinux.org>
# Contributor: Kuba Kuźma <kuba@jah.pl>
# Contributor: Matthew Carter <m@ahungry.com>
# Contributor: Ariel Popper <a@arielp.com>
pkgname=postgresql-9.6
pkgver=9.6.6
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.postgresql.org/"
pkgdesc="A powerful, open source object-relational database system"
@@ -44,30 +46,27 @@ build() {
--with-krb5 \
--with-gssapi \
--with-libxml \
- --with-openssl-1.0 \
+ --with-openssl \
--with-perl \
--with-python PYTHON=/usr/bin/python2 \
--with-tcl \
--with-pam \
--with-system-tzdata=/usr/share/zoneinfo \
+ --with-uuid=e2fs \
--enable-nls \
--enable-thread-safety
- make
- make -C contrib
+ make world
}
package() {
cd "${srcdir}/postgresql-${pkgver}"
+ make DESTDIR="${pkgdir}" install-world
+
# install license
install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- make DESTDIR="${pkgdir}" install
- make -C contrib DESTDIR="${pkgdir}" install
-
-# install -D -m644 "${srcdir}/postgresql.tmpfiles.conf" \
-# "${pkgdir}/usr/lib/tmpfiles.d/postgresql.conf"
install -D -m644 "${srcdir}/postgresql.service" \
"${pkgdir}/usr/lib/systemd/system/postgresql.service"
install -D -m755 "${srcdir}/postgresql-check-db-dir" \