summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-04-25 16:00:52 +0200
committerGoliathLabs2020-04-25 16:00:52 +0200
commit06e75a2208ace8aac507cc4cff34118d7c8dcd66 (patch)
tree4806f4096c5c34b1e2ee9fef6473eae355ff0405 /PKGBUILD
parent9fdd3562d67112ed1a17c0238dbee0c4474d510b (diff)
downloadaur-06e75a2208ace8aac507cc4cff34118d7c8dcd66.tar.gz
Updated: PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 34 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54a939604dd3..ee1924b905a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,52 @@
-# Maintainer: Thomas Arnhold <thomas@arnhold.org>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Thomas Arnhold <thomas@arnhold.org>
# Contributor: Ariel Popper <a@arielp.com>
# Contributor: Dan McGee <dan@archlinux.org>
pkgname=postgresql-92-upgrade
pkgver=9.2.24
_majorver=${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="PostgreSQL build for migrating between major versions with pg_upgrade"
-arch=('i686' 'x86_64')
url="http://www.postgresql.org/"
+arch=('i686' 'x86_64')
license=('custom:PostgreSQL')
-depends=("postgresql-libs>=${_majorver}" 'libxml2' 'openssl>=1.0.0' 'pam')
-makedepends=('krb5' 'python2' 'perl' 'tcl>=8.6.0')
+depends=("postgresql-libs>=${_majorver}" 'libxml2' 'openssl>=1.0.0' 'pam'
+ 'zlib' 'icu' 'systemd-libs' 'libldap' 'krb5')
+makedepends=('python' 'python2' 'perl' 'tcl>=8.6.0' 'systemd')
+optdepends=('python2: for PL/Python 2 support'
+ 'python: for PL/Python 3 support'
+ 'perl: for PL/Perl support'
+ 'tcl: for PL/Tcl support')
provides=("postgresql-92-upgrade=${_majorver}")
conflicts=('postgresql-old-upgrade' 'postgresql-lts-old-upgrade')
-source=(http://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2)
+source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2)
sha256sums=('a754c02f7051c2f21e52f8669a421b50485afcde9a581674d6106326b189d126')
build() {
cd "${srcdir}/postgresql-${pkgver}"
-
- ./configure \
- --prefix=/opt/pgsql-${_majorver} \
- --with-gssapi \
- --with-libxml \
- --with-openssl \
- --with-perl \
- --with-python PYTHON=/usr/bin/python2 \
- --with-tcl \
- --with-pam \
- --without-readline \
- --with-system-tzdata=/usr/share/zoneinfo \
- --disable-nls \
+ local options=(
+ --prefix=/opt/pgsql-${_majorver}
+ --with-gssapi
+ --with-libxml
+ --with-openssl
+ --with-perl
+ --with-python
+ --with-tcl
+ --with-pam
+ --without-readline
+ --with-system-tzdata=/usr/share/zoneinfo
+ --with-uuid=e2fs
+ --with-icu
+ --with-systemd
+ --with-ldap
+ --disable-nls
--enable-thread-safety
+ )
+ # regular build with everything
+ ./configure ${options[@]} \
+ PYTHON=/usr/bin/python2
make -C src all
make -C contrib all
}
@@ -46,9 +59,8 @@ package() {
make -C contrib DESTDIR="${pkgdir}" install
# install license
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
- # clean up unneeded installed items
+ ## clean up unneeded installed items
rm -rf "${pkgdir}/opt/pgsql-${_majorver}/include/"
}
-