summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Preinstorfer2015-06-08 19:40:09 +0200
committerFlorian Preinstorfer2015-06-08 19:40:09 +0200
commit84fe0aad9b5c92c8d87349c4a9da75ff4f68ebf0 (patch)
treee9d4187adc85d85b33d923f1ae2b95bf592dd5d3 /PKGBUILD
downloadaur-84fe0aad9b5c92c8d87349c4a9da75ff4f68ebf0.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e88e772989c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: nblock <nblock [/at\] archlinux DOT us
+# Contributor: Gustavo Dutra <mechamo@gustavodutra.com>
+
+pkgname=postgresql-autodoc
+_pkgname=postgresql_autodoc
+pkgver=1.41
+pkgrel=4
+pkgdesc="Translate PostgreSQL tables to HTML, Dot, Dia and DocBook XML files."
+url="https://web.archive.org/web/20130712095001/http://www.rbt.ca/autodoc/index.html"
+license=("3-clause BSD")
+depends=('perl' 'perl-dbd-pg' 'perl-term-readkey' 'perl-html-template')
+arch=('any')
+source=(https://web.archive.org/web/20130712095001/http://www.rbt.ca/autodoc/binaries//${_pkgname}-${pkgver}.tar.gz)
+md5sums=('a23ae4a49bfd0c14375b3ea6e04cd5b9')
+
+build() {
+ cd ${srcdir}/${_pkgname}
+
+ # Prepare the binary, but skip the manpage since upstream
+ # forgot to include manpage source (postgresql_autodoc.in)
+ make -o ${_pkgname}.1 PREFIX=/usr
+
+ # Fixup the default path in the manpage, until a proper upstream fix is available.
+ sed -i -e "s|/usr/local/share/postgresql_autodoc|/usr/share/${_pkgname}|" ${_pkgname}.1
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+ make -o ${_pkgname}.1 install PREFIX=/usr DESTDIR=${pkgdir}
+
+ # Fix manpage permission
+ chmod 644 ${pkgdir}/usr/share/man/man1/${_pkgname}.1
+}
+
+# vim:set ts=2 sw=2 noet: