summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212023-08-27 11:54:01 +0200
committera8212023-08-27 11:54:01 +0200
commit4bcf585165dea8a5267ca306921c7334141ae473 (patch)
tree296fb091ac351b8b84ddbfe8916b7dbd0816c452 /PKGBUILD
parent21124d510adbbcd4cc79a04b84d0e88df30d8de0 (diff)
downloadaur-4bcf585165dea8a5267ca306921c7334141ae473.tar.gz
Switch to LLVM 15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23146c308886..69b1081b0b35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
pkgbase=postgresql-beta
pkgname=('postgresql-beta-libs' 'postgresql-beta-docs' 'postgresql-beta')
pkgver=16beta3
-pkgrel=1
+pkgrel=2
pkgdesc='Sophisticated object-relational DBMS'
url='https://www.postgresql.org/'
arch=('x86_64')
license=('custom:PostgreSQL')
makedepends=('krb5' 'libxml2' 'python' 'perl' 'tcl' 'openssl'
- 'pam' 'zlib' 'icu' 'systemd' 'libldap' 'llvm' 'clang' 'libxslt'
+ 'pam' 'zlib' 'icu' 'systemd' 'libldap' 'llvm15' 'clang15' 'libxslt'
'util-linux')
source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
postgresql-run-socket.patch
@@ -72,6 +72,7 @@ build() {
CFLAGS+=" -ffat-lto-objects"
# regular build with everything
+ LLVM_CONFIG=llvm-config-15 CLANG=/usr/lib/llvm15/bin/clang \
./configure "${configure_options[@]}"
make world
}
@@ -153,7 +154,7 @@ package_postgresql-beta() {
pkgdesc='Sophisticated object-relational DBMS'
backup=('etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
depends=("postgresql-beta-libs" 'krb5' 'libxml2' 'readline'
- 'openssl' 'pam' 'icu' 'systemd-libs' 'libldap' 'llvm-libs'
+ 'openssl' 'pam' 'icu' 'systemd-libs' 'libldap' 'llvm15-libs'
'libxslt' 'lz4' 'zstd')
optdepends=('python: for PL/Python 3 support'
'perl: for PL/Perl support'