summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNoah Gumbert2023-12-19 12:37:19 +1100
committerNoah Gumbert2023-12-19 12:37:19 +1100
commitdd842de25e42b23caf8be866a5b5922e25e17caf (patch)
treeb93656b7a8a0fae1f1f185562478e6e118b3f892 /PKGBUILD
downloadaur-dd842de25e42b23caf8be866a5b5922e25e17caf.tar.gz
package creation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0526f6a08b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+#Maintainer: Ponies <marmabelle at gmail dot com>
+pkgname=postman-cli
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="The Postman CLI is the command-line companion that is developed, supported, and signed by Postman. It enables you to run collections, lint API schemas, run security and governance checks, and log in and out. All test results will be automatically pushed to the app."
+provides=('postman-cli')
+arch=('x86_64')
+options=("!strip")
+url="https://www.postman.com/product/what-is-postman/"
+license=('custom')
+source=("postman-cli.tar.gz::https://dl-cli.pstmn.io/download/latest/linux64")
+depends=(libxss nss)
+
+sha256sums=('45a205d2dcc90399fe736fa95ac36304dcbd12977214cb6b3070f17205f780b7')
+prepare(){
+ cd "$srcdir"
+ tar -xzf postman-cli.tar.gz
+}
+package() {
+ install -dm755 "$pkgdir/usr/bin/"
+ cp "${srcdir}/postman-cli" "${pkgdir}/usr/bin/"
+}