summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2018-02-02 17:05:37 +0100
committerEduardo Sánchez Muñoz2018-02-02 17:05:37 +0100
commit6ad65ff6207021fc3a6b3020d4df6615ff9a8893 (patch)
tree9f3e97fafe9d95757daece16066b7625aeb9b9c3 /PKGBUILD
parentbc77c401c1c3bc6a6bb8fe9f0bcda1d1382603e8 (diff)
downloadaur-6ad65ff6207021fc3a6b3020d4df6615ff9a8893.tar.gz
Add menu entry.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b6dfb7691be..754c021c2e1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,27 @@
pkgname=pothos
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="The Pothos data-flow framework"
arch=('i686' 'x86_64')
url="https://github.com/pothosware/PothosCore/wiki"
license=('boost')
-depends=('python' 'poco' 'soapysdr-git' 'portaudio')
+depends=('python' 'poco' 'qwt' 'soapysdr-git' 'portaudio')
makedepends=('git' 'nlohmann-json')
-source=("git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver")
-sha256sums=('SKIP')
+source=(
+ "git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver"
+ "PothosFlow.desktop"
+)
+sha256sums=(
+ 'SKIP'
+ '4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4'
+)
prepare() {
cd "$srcdir/PothosCore"
- git submodule update --init --recursive
+ git submodule init
+ git submodule deinit poco
+ git submodule update --recursive
}
build() {
@@ -24,6 +32,9 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_INTERNAL_POCO=OFF \
+ -DENABLE_INTERNAL_MUPARSERX=ON \
+ -DENABLE_INTERNAL_SPUCE=ON \
"$srcdir/PothosCore"
make
}
@@ -31,4 +42,8 @@ build() {
package() {
cd "$srcdir/pothos-build"
make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/PothosFlow.desktop" "$pkgdir/usr/share/applications/PothosFlow.desktop"
+ install -d "$pkgdir/usr/share/pixmaps"
+ convert "$srcdir/PothosCore/flow/icons/PothosFlow.ico" "$pkgdir/usr/share/pixmaps/PothosFlow.png"
}