summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2020-07-20 12:15:50 +0200
committerEduardo Sánchez Muñoz2020-07-20 12:15:50 +0200
commitda65b6b9f39628492dd565aecc5a3947e0aa38fc (patch)
treed22551e811c7c0fd81f9d7eda3c708b33d50659c /PKGBUILD
parent8c3d890ef4633f5824792017c49e97ab6ce5e23d (diff)
downloadaur-da65b6b9f39628492dd565aecc5a3947e0aa38fc.tar.gz
Update to version 0.7.0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b26b627965c..f2210fb0a35e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,20 @@
# Contributor: Sebastien Chassot (sinux) <seba.ptl@sinux.net>
pkgname=pothos
-pkgver=0.6.1
+pkgver=0.7.0
pkgrel=1
pkgdesc="The Pothos data-flow framework"
arch=('i686' 'x86_64')
url="https://github.com/pothosware/PothosCore/wiki"
license=('boost')
-depends=('python' 'poco' 'qwt' 'soapysdr-git' 'portaudio')
+depends=('python' 'poco' 'soapysdr' 'portaudio')
makedepends=('git' 'nlohmann-json')
source=(
"git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver"
- "spuce-qt-workaround.diff"
"PothosFlow.desktop"
)
sha256sums=(
'SKIP'
- '3bc94fcdd8a944a58906294d35ec8e2bde2ae6d53806f3413c8c302172058f3f'
'4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4'
)
@@ -25,10 +23,9 @@ prepare() {
cd "$srcdir/PothosCore"
git submodule init
git submodule deinit poco
- git submodule update --recursive --force
-
- cd spuce
- git apply "$srcdir/spuce-qt-workaround.diff"
+ git submodule update --recursive
+ # Init submodules in plotters
+ git submodule update --init --recursive plotters
}
build() {
@@ -47,7 +44,7 @@ build() {
package() {
cd "$srcdir/pothos-build"
make DESTDIR="$pkgdir" install
-
+
install -Dm644 "$srcdir/PothosFlow.desktop" "$pkgdir/usr/share/applications/PothosFlow.desktop"
install -Dm644 "$srcdir/PothosCore/flow/icons/PothosFlow.png" "$pkgdir/usr/share/pixmaps/PothosFlow.png"
}