summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2017-12-26 14:43:21 +0100
committerEduardo Sánchez Muñoz2017-12-26 14:43:21 +0100
commitda9278dac5bf3c829b735d8a3c28ecf3b6aa6e7e (patch)
tree15926c50b11860c35f47578dca69c1ee79a4a243 /PKGBUILD
downloadaur-da9278dac5bf3c829b735d8a3c28ecf3b6aa6e7e.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..004c7c73c717
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Eduardo Sánchez Muñoz (eduardosm)
+# Contributor: Sebastien Chassot (sinux) <seba.ptl@sinux.net>
+
+pkgname=pothos
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="The Pothos data-flow framework"
+arch=('i686' 'x86_64')
+url="https://github.com/pothosware/PothosCore/wiki"
+license=('Boost Software License')
+depends=('python' 'poco' 'soapysdr-git' 'portaudio')
+makedepends=('git' 'nlohmann-json')
+source=("git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/PothosCore"
+ git submodule update --init --recursive
+}
+
+build() {
+ mkdir -p "$srcdir/pothos-build"
+ cd "$srcdir/pothos-build"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ "$srcdir/PothosCore"
+ make
+}
+
+package() {
+ cd "$srcdir/pothos-build"
+ make DESTDIR="$pkgdir" install
+}