summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Majewski2020-09-11 10:56:54 +0200
committerKevin Majewski2020-09-11 10:56:54 +0200
commit81a197852e1812e877b0a4a00a5eb02d054cdfc4 (patch)
tree8dbcc7da80443f80c462ea3d07bf39b677f05198 /PKGBUILD
downloadaur-81a197852e1812e877b0a4a00a5eb02d054cdfc4.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c331db97d214
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=power-profiles-daemon
+pkgver=0.1
+pkgrel=1
+pkgdesc="Makes power profiles handling available over D-Bus"
+url="https://gitlab.freedesktop.org/hadess/power-profiles-daemon"
+license=(GPL3)
+arch=(x86_64)
+depends=('libgudev' 'systemd')
+makedepends=('git' 'meson')
+_commit=dfeeebc9294b1ece5b0a1f797e4886b747640849
+source=("git+https://gitlab.freedesktop.org/hadess/power-profiles-daemon.git#commit=$_commit")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}