summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKillswitch2020-08-15 16:06:43 +0200
committerKillswitch2020-08-15 16:06:43 +0200
commit91afcdf3d4ba0b4c8af31a944e2202b2940d11bd (patch)
treeaefa7888ba58926beb639d307a450428017f0292 /PKGBUILD
parent60ee0bb32b07d39bed729b55f8b76f52bfd395b4 (diff)
downloadaur-91afcdf3d4ba0b4c8af31a944e2202b2940d11bd.tar.gz
Edtied pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 709b09211d3a..146f562ad418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,9 +34,7 @@ package() {
local install_dir="${pkgdir}/opt"
install -d "${install_dir}"
- cp -a "${srcdir}/${_pkgname}" "${install_dir}"
- chmod 755 "${install_dir}/${_pkgname}"
-
+ cp -a "${srcdir}/${_pkgname}" "${install_dir}"
cd "${install_dir}/${_pkgname}"
npm install --only=prod
@@ -58,6 +56,9 @@ package() {
install -g 0 -o 0 -Dm 0644 "${srcdir}/${patches}/powercord.8" -t ${pkgdir}/usr/share/man/man8/
gzip ${pkgdir}/usr/share/man/man8/powercord.8
+ # This is not ideal. It's only required because it seems like discord needs write and execute permissions.
+ chmod -R 757 "${install_dir}/${_pkgname}"
+
echo -e "\e[5m\e[101mWARNING"
echo -e "\e[5m\e[101mWARNING\e[49m \e[91m \e[4mUsing this tool could get you banned. Read the whole disclaimer on the github page!\e[0m\e[39m"
echo -e "\e[5m\e[101mWARNING\e[39m\e[49m"